File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Other JSE/JEE APIs and the fly likes autowiring problem when deploying on Jboss through eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Other JSE/JEE APIs
Bookmark "autowiring problem when deploying on Jboss through eclipse" Watch "autowiring problem when deploying on Jboss through eclipse" New topic
Author

autowiring problem when deploying on Jboss through eclipse

saad bousf
Greenhorn

Joined: Nov 01, 2011
Posts: 6
I'm developping an application using Jboss-4.2.3.GA, spring 3.1.0.RC1 (framework, aop,...), Maven 3.3 and eclipse Indigo. If i deploy my webApp on Jboss using a command line jboss:deploy without using Eclipse, the project is deployed corrctly and i run my application very well. Now, for quick testing and deploying purpose, i want to use Eclipse to deploy the same web app on a jboss server added to eclipse servers and linked to the same external jboss server. The entry to my web app is always the same: a simple servlet (Bonjour.java) wich must call an autowired spring bean (promoteurPresInt) . The problem is that this bean is not wired. Debug shows that it's null.

Web.xml:




spring-context-ressources.xml:


the bean PromoteurPres.java:



the interface implemented by my bean

PromoteurPresInt.java:




La servelett Bonjour.java:




It seems like jboss need some additional library or config when launching a spring application on it through eclipse???
Pliz Save me!
 
 
subject: autowiring problem when deploying on Jboss through eclipse