Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

the mythical WAS work-around

 
Kris Ten
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So, I'm working on a Struts app with WebSphere Studio Enterprise Developer (similar to WSAD) with WAS 5.1. The built-in support is for Struts 1.1, but I want to use Struts 1.3.5. Since the application I'm updating was created with the built-in Struts support, I deleted all the Struts 1.1 specific jars, updated the DOCTYPEs of the xml files (struts-config & validation), and updated the validator plug-in as well. It *seems* to work in my workspace; however, when I deploy the app to our test environment, I think the server is looking for built-in Struts capabilities, which aren't there. Is there any way to "unsupport Struts" in my application according to WebSphere (but still use Struts 1.3.5) so that WAS can quit screwing up?

Any info or suggestions would be greatly appreciated.

Cheers,
Kristen
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've worked with WebSphere for a number of years, and I've deployed Struts in versions other than 1.1 to WAS servers, and haven't had a problem. I will admint that I've never tried to deploy a Struts 1.3.5 app to WAS, though. One thing I would suggest is to make sure that you don't have any Struts-related jar files in any of the common lib directories. Make sure the only struts artificats are the ones in your application.

If this doesn't work, let us know what error messages or other symptoms you're getting when you deploy this app.
 
Kris Ten
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think I found the issue. When a web project in the IDE is created to use WebSphere's built-in Struts support, it adds some features to the .websettings file that (I'm assuming, and we all know what happens when I do that ) attempt to run the newer version of Struts I'm using (1.3.5) through the same set-up that the built-in version of Struts is expecting (v 1.1). I'm going to try to delete the features from the web settings xml and see where that gets me.

Thanks for your help, and have a good weekend! You may be hearing from me on Monday!


Kristen
 
Arulanand Dayalan
Ranch Hand
Posts: 127
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you create a web project there is an option provided to specify you need struts support or not. So uncheck that and create a web project. Later on add the required jar files and choose the class loading policy such that it load the files from your webproject itself.

Hope this helps.

Thanks and Regards,
Arul.
 
Kris Ten
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the suggestion! That definitely worked (as I thought it would ); however, the copy-and-paste associated with doing that was rather excessive for just the small project I was working on, and I'm concerned about having larger projects that want to convert to a newer version, so I was looking for a way to tell people to change things in their existing projects so that they wouldn't have to create new ones. Part of the reason I want to do this is because we use the Serena Version Manager repository, which is finicky in the first place, and extra obnoxious if you try to check in files from a different location than where they were checked out.

Anyway, thank you again. The solution was stellar!


Kristen
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic