*
The moose likes Applets and the fly likes Button does not show in applet on newer version of Safari Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "Button does not show in applet on newer version of Safari" Watch "Button does not show in applet on newer version of Safari" New topic
Author

Button does not show in applet on newer version of Safari

Haina Minawa
Ranch Hand

Joined: Oct 13, 2011
Posts: 119
I have an applet that has only one button.
Upon loading, the button shows up nicely on Safari 5.0. However it does not show up for the first time in Safari 5.1, and if I refresh the page, it does show!
Is the problem due to Safari? I tried to use applet's validate() and repaint() but the button still does not show for the first time.
The problem happens only on Safari 5.1.

Does anyone face the same problem or have any ideas?

Thanks.
gyan kumar
Ranch Hand

Joined: Sep 28, 2011
Posts: 61
before running again try to delete the cache and cookies if you face the problem again please post code in forum.
Haina Minawa
Ranch Hand

Joined: Oct 13, 2011
Posts: 119
gyan kumar wrote:before running again try to delete the cache and cookies if you face the problem again please post code in forum.

Yes, I empty the cache every time running the applet, the button still invisible in the newer Safari. But the older Safari shows the button correctly. Strange!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Button does not show in applet on newer version of Safari