File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Web Services and the fly likes Standalone Web Service Application with Java 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Standalone Web Service Application with Java 5" Watch "Standalone Web Service Application with Java 5" New topic

Standalone Web Service Application with Java 5

Rahul Chaitanya

Joined: Aug 22, 2010
Posts: 22

I will have to develop a standalone webservice app with Java 5. Initially, i developed it with Java 6 but our company only uses Java 5 and so i just modified my Eclipse compilance settings to Java 1.5 and using Java5 - Jdk.

Here, comes the problem:
Ecipse is throwing an error saying that it was not able to resolve below packages
import,import javax.jws.WebService

But, I see that java 5 also supports Jax-Ws and it do has the above mentioned packages. But why does my eclipse is throwing errors ? Is this because .. i might be using older version with JDK 1.5 ?

I manually added above jars to my project build path, it removed the error but when i run the application is throwing an exception saying different version in the .class file. I guess the jar files i added were implemented with Java 6. Can any one help me in getting those jar files that were build using Java 5 ?

If my approach isn't good ..please, suggest any other approaches. Remember, the importance here is i will have to develop standalone web service application.

Thanks in advance.
It is sorta covered in the JavaRanch Style Guide.
subject: Standalone Web Service Application with Java 5
It's not a secret anymore!