wood burning stoves 2.0*
The moose likes Struts and the fly likes First Struts Application works well in (browser!=Chrome) !!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "First Struts Application works well in (browser!=Chrome) !!!" Watch "First Struts Application works well in (browser!=Chrome) !!!" New topic
Author

First Struts Application works well in (browser!=Chrome) !!!

Salvo Montalbano
Greenhorn

Joined: Sep 22, 2011
Posts: 11
Hi all,

i'm at the beginning about studying the Struts 2 framework.
I'm following some examples and I deployed my first Struts2 application.
I noticed a strange problem: if I type in my browser the URL http://localhost:8080/struts2tutorial/, application works well only with Firefox and IE. If I use Chrome I have the following message:

Struts Problem Report

Struts has detected an unhandled exception:

Messages:
There is no Action mapped for action name HelloWorld.


The application shoud display an index.html page which contains a link to HelloWorld.action
In Firefox and IE this page appears and I can click on the link in order to execute the action, but with Chrome I have the previous error.
Can anyone explain me this different behaviour?
Thanks in advance

SM

Salvo Montalbano
Greenhorn

Joined: Sep 22, 2011
Posts: 11
Damn! I found the solution after my post (and after a lot of hours!)
http://www.roseindia.net/tutorialhelp/comment/30472
The problem is about the index.html file inside the struts2tutorial example!
After editing the file, browser's cache must be cleaned (this caused the difference about Firefox/IE vs Chrome)
I'm a very newbie...
I hope this post will be useful to another newbie
Haina Minawa
Ranch Hand

Joined: Oct 13, 2011
Posts: 119
Salvo Montalbano wrote:Damn! I found the solution after my post (and after a lot of hours!)
http://www.roseindia.net/tutorialhelp/comment/30472
The problem is about the index.html file inside the struts2tutorial example!
After editing the file, browser's cache must be cleaned (this caused the difference about Firefox/IE vs Chrome)
I'm a very newbie...
I hope this post will be useful to another newbie


Thanks for sharing the information. If you run the project in Eclipse and look at the console, you will spot the problem quickly.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: First Struts Application works well in (browser!=Chrome) !!!
 
Similar Threads
Problem with popup window.
problem with submit and redirection
problem with submit and redirection {javascipt struts under google chrome}
problem with submit and redirection {javascipt struts under google chrome}
Java mail problem in IE