This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes Linux / UNIX and the fly likes Java Media Framework (eclipse) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Java Media Framework (eclipse)" Watch "Java Media Framework (eclipse)" New topic
Author

Java Media Framework (eclipse)

Adalberto Toledo
Greenhorn

Joined: Mar 10, 2011
Posts: 14
Hi, I'm using Linux Ubuntu version 10.04 LTS
I installed Java Media Framework with the .bin file for linux downloaded from oracle web page

It installed property but I'm having these problems:

* When I run the comand "java JMStudio" as a root user (#) the mpg video plays good but when I run that comand as simple user ($), the mpg video send me this error: "Controller error: Failed to realize"
* When I run eclipse as a root user (#) and I run a program that uses the jmf libraries, the video play good but without audio and the console says: "Failed to initialize audio for mpx."
* When I run eclipse as a simple user ($) and I run a program that uses the jmf libraries, the console says: "Error: Unable to realize"


What Can I do to solve these problems...? Please help me...
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10744
    
    9

This question looks like it would be more suitable on the Linux forum. Moving.


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 17030
    
  26

It's very likely that the user account in question doesn't have access rights to the various media devices such as the /dev/snd and /dev/video device "files".

Depending on the distro you're using and how things were installed, there may be a security group defined for such things that you can add the user to. Or if not, you could create one.

Also check selinux for possible violations, but I think it's more likely that the basic access rights are the main issue here.


An IDE is no substitute for an Intelligent Developer.
luke swagger
Greenhorn

Joined: Dec 22, 2011
Posts: 3

I have added the all the jars in the lib folder to the eclipse class path
by going to:

windows > java > build path > class variables > new

I tried adding just the folder but have also tried adding all the jars
separately. I made a quick test by writing a program that just imports

Samsung Galaxy Tab accessories
wave power
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Java Media Framework (eclipse)
 
It's not a secret anymore!