aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Migration from STS to Eclipse build/publish to Tomcat not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Migration from STS to Eclipse build/publish to Tomcat not working" Watch "Migration from STS to Eclipse build/publish to Tomcat not working" New topic
Author

Migration from STS to Eclipse build/publish to Tomcat not working

Pranav Sharma
Ranch Hand

Joined: Oct 27, 2003
Posts: 256
Hi
I'm migrating my project from Spring Tool Suite to Eclipse Helios as I was not happy with STS performance. However I have run into problems with building and publish to Tomcat in eclipse.

Seems like any change resources is not detected by eclipse and does not kick off an auto rebuild or publish. I have tried manually cleaning, building, cleaning Tomcat republishing, even deleting the app folder in .metadata\.plugins\org.eclipse.wst.server.core\ with no avail.

Tomcat is set to republish with change to resource and eclipse is set to auto-build.

Any help in this regard would be great help. Thanks.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Migration from STS to Eclipse build/publish to Tomcat not working
 
Similar Threads
eclipse sts cannot start tomcat: ports already in use
Do you use in maven ear to build your ear in dev env?
Question on Log4j NOT restarting
pros/cons auto-build feature inside IDE
Eclipse3.0 Build all and build project not working