aspose file tools*
The moose likes Oracle/OAS and the fly likes network adopter could not establish connection..? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Oracle/OAS
Bookmark "network adopter could not establish connection..?" Watch "network adopter could not establish connection..?" New topic
Author

network adopter could not establish connection..?

mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

Hi,
I just installed ORACLE 11g in my new laptop(WINDOWS-7 OS) and it connect to DB successfully by using sql-developer and i am getting data form scott.But my friend want to connect to my data base and he could not make it it is giving the fallowing error.
"file io- exception :network adopter could not establish connection"

i checked my host name (tried IP and system name also) and user name and password are correct SID also.
In my system SQL Developer I just try to replace "localhost" with my system name and my ip address it is giving same error.
F.Y.I
His system is windows XP ssp3
my friend is able to ping my system and access my shared folders and mine to.
I am able to connect to his db.
we are on same network and user group.
all the oracle services are turned on.

please help me..thanks in advance
Martin Vajsar
Sheriff

Joined: Aug 22, 2010
Posts: 3611
    
  60

This is most probably a firewall problem. Configure your firewall on the Windows 7 machine to allow external access to oracle.exe and TNSLSNR.EXE, both found in the BIN directory inside your Oracle home. You can quickly verify this is indeed a firewall issue by turning it off completely for a few moments, if it works then, you'll know the culprit.

The other direction probably works because firewall in Windows XP was much more permissive by default, if I recall correctly, or maybe the firewall is turned off on that machine.
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

I turned off firewall(MacAfee) and restarted my system but it is still showing same error.
Martin Vajsar
Sheriff

Joined: Aug 22, 2010
Posts: 3611
    
  60

mallikarjun dontamsetti wrote:I turned off firewall(MacAfee) and restarted my system but it is still showing same error.

And is the Windows firewall turned off too? MacAffee is not the only one on your system. It still sounds like firewall issue, check firewalls on both sides carefully.
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

My window's firewall is also maintained by MacAfee wwhich i turned off.
Martin Vajsar
Sheriff

Joined: Aug 22, 2010
Posts: 3611
    
  60

You could try suggestions from this thread. I would not be able to advice anything more than already said there.

By the way, I googled your error message and that thread was in the top three results.
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

i just tried

TELNET <ip> <port> in command prompt it is showing that "Connecting To 192.168.10.116... Could not open connection to the host, on port 1521: Connect failed"
how to open this port
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: network adopter could not establish connection..?