This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jboss Memory out of error when generating BIRT Reports

 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys,
I have a big issue with my project. when I launch it on my local machine all BIRT reports and ohter functionalities of my project works fine. but when I deployed it to Jboss server (.ear) for normal operations works fine. when generating a report jboss gives out of memory error. this happens when i generate small report even. after that i should restart the jboss server. PLEASE HELP ME............. the error as follows.

 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You ran out of permgen space. Try increasing that (-XX:MaxPermSize), it is one of the JAVA_OPTS settings in run.conf or run.conf.bat.

By the way which OS and what version of JBoss AS?
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I already increased the size but problem exists samae.it's windows server 2003 and jboss 5.1
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you running JBoss AS as a service using service.bat? If so, have you seen this: https://issues.jboss.org/browse/JBNATIVE-59

If you are not running as a service, when JBoss AS starts it prints out the JAVA_OPTS settings, post that.
 
Gihan Pandigamage
Ranch Hand
Posts: 60
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank guys it was fixed.
This is the way I fix it.
cut the "set JAVA_OPTS=-Xrs" option from jboss-5.1.0.GA\bin\service.bat file and paste it to jboss-5.1.0.GA\bin\run.config.bat before the "set JAVA_OPTS=-Xms128M -Xmx512M -XX:MaxPermSize=1024M" line
now the run.config.bat file looks like this.

Thank you very much Peter for helping me.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And thank you for providing the details on your fix, that will help others later that come across this post.
 
Don't get me started about those stupid light bulbs.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic