Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Security Realm in Cluster - Managed Server

 
ChynChwen Heng
Greenhorn
Posts: 1
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys, I have a problem with the Security Realm setting in a cluster setup -

The environment I am using -
Weblogic - 11gR1
Windows 2003 server
no node manager being configured

1. Physical Server1
- Cluster setup
- Admin Server
- Managed Server 1
- Added 1 new user in default security realm via the admin console

2. Physical Server2
- Cluster setup
- Managed Server 2

When I am using the form authentication in jsp page (post to j_security_check) - the page is working in Server1 but NOT working in Server2.

I suspect the new user that I added in the default security realm is not replicate to managed server 2, may I know is there any setup or deployment setting I need to do ?

Thanks !
 
Arend VogtlÃĪnder
Greenhorn
Posts: 3
Java Linux Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
as this topic seems to be well aged, i would like to ask, if there was a solution found.

One of our Customers seems to run into the same Problem, but as i am trying to reenact it does not provoke the same failure...
We have a similar Setup:
- WebLogic AdminServer (10.3.6) on SLES11
- ManagedServer on same Machine
- ManagedServer on remote Machine
- nodemanager-service connecting the whole bunch (which seems to be a difference here, but i don't think this is crucial)

for our application login we do use our own securityprovider inside the standard security-realm, which works fine on all managedservers (our customer can only use it on one managedserver, but it fails on the second one)
my main question now is: where is the configuration about applications and/or managedservers using securityproviders stored, so that i can help him compare his managedservers to hopefully find a difference?

i have been searching a lot in die adminsercer-console, but there seems to be no such connection between managedservers and securityproviders.

any ideas?

thanks a lot,
arend
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic