wood burning stoves 2.0*
The moose likes Websphere and the fly likes Websphere Startup Issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Websphere Startup Issues" Watch "Websphere Startup Issues" New topic
Author

Websphere Startup Issues

Mary Chellapa
Ranch Hand

Joined: Jul 26, 2011
Posts: 93
Environment : RAD 6 , Websphere 6

When i started the server earlier today i got a conflict at port 8880
SO i found out what wa srunnign on that port and killed the process ( java.exe)
i restarted the server ..i see following in error logs but on console
it says "ADMU3000I: Server server1 open for e-business; process id is 1048"

Any insights please??

[12/27/11 10:25:42:714 EST] 0000001b ApplicationMg A WSVR0221I: Application started: adminconsole
[12/27/11 10:25:42:714 EST] 00000019 ApplicationMg A WSVR0200I: Starting application: WC
[12/27/11 10:25:43:761 EST] 00000019 ApplicationMg E WSVR0101W: An error occurred starting, WC
[12/27/11 10:25:43:776 EST] 00000019 ApplicationMg A WSVR0217I: Stopping application: WC
[12/27/11 10:25:43:917 EST] 00000019 ApplicationMg A WSVR0220I: Application stopped: WC
[12/27/11 10:25:43:948 EST] 0000000a ContainerImpl E WSVR0501E: Error creating component null [class com.ibm.ws.runtime.component.ApplicationMgrImpl]
com.ibm.ws.exception.RuntimeWarning: com.ibm.ws.exception.RuntimeError: com.ibm.etools.j2ee.commonarchivecore.exception.NoModuleFileException: A file does not exist for module element having uri: ESBAvailableReportJMSRouter.jar
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplications(ApplicationMgrImpl.java:795)


Mary
uday kantt
Greenhorn

Joined: May 05, 2011
Posts: 26

Hi Mary
I think that the log message you see was the log message that was created when first time the server start up failed. So why not clear the log message file and try again, you may not find any errors this time.
Mary Chellapa
Ranch Hand

Joined: Jul 26, 2011
Posts: 93
Hi Uday,
Thanks for reply. No its after .. i just run it again ... same issue

[12/28/11 9:25:01:340 EST] 0000001d ApplicationMg A WSVR0200I: Starting application: WC
[12/28/11 9:25:02:293 EST] 0000001d ApplicationMg E WSVR0101W: An error occurred starting, WC
[12/28/11 9:25:02:309 EST] 0000001d ApplicationMg A WSVR0217I: Stopping application: WC
[12/28/11 9:25:02:465 EST] 0000001d ApplicationMg A WSVR0220I: Application stopped: WC
[12/28/11 9:25:02:496 EST] 0000000a ContainerImpl E WSVR0501E: Error creating component null [class com.ibm.ws.runtime.component.ApplicationMgrImpl]
com.ibm.ws.exception.RuntimeWarning: com.ibm.ws.exception.RuntimeError: com.ibm.etools.j2ee.commonarchivecore.exception.NoModuleFileException: A file does not exist for module element having uri: ESBAvailableReportJMSRouter.jar
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplications(ApplicationMgrImpl.java:795)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:542)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:820)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:649)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationServerImpl.java:149)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:820)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:649)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:444)
at com.ibm.ws.runtime.WsServerImpl.bootServerContainer(WsServerImpl.java:187)
at com.ibm.ws.runtime.WsServerImpl.start(WsServerImpl.java:133)
at com.ibm.ws.runtime.WsServerImpl.main(WsServerImpl.java:387)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:53)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
at java.lang.reflect.Method.invoke(Method.java:391)
at com.ibm.ws.bootstrap.WSLauncher.run(WSLauncher.java:219)
at java.lang.Thread.run(Thread.java:571)
Caused by: com.ibm.ws.exception.RuntimeError: com.ibm.etools.j2ee.commonarchivecore.exception.NoModuleFileException: A file does not exist for module element having uri: ESBAvailableReportJMSRouter.jar
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:942)
at com.ibm.ws.runtime.component.ApplicationMgrImpl$AppInitializer.run(ApplicationMgrImpl.java:2070)
at com.ibm.ws.runtime.component.ComponentImpl$_AsynchInitializer.run(ComponentImpl.java:304)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1475)
Caused by: com.ibm.etools.j2ee.commonarchivecore.exception.NoModuleFileException: A file does not exist for module element having uri: ESBAvailableReportJMSRouter.jar
at com.ibm.etools.j2ee.commonarchivecore.impl.ModuleRefImpl.checkType(ModuleRefImpl.java:492)
at com.ibm.etools.j2ee.commonarchivecore.impl.ModuleRefImpl.initModuleFileFromEAR(ModuleRefImpl.java:120)
at com.ibm.etools.j2ee.commonarchivecore.impl.ModuleRefImpl.getModuleFile(ModuleRefImpl.java:98)
at com.ibm.ws.classloader.ClassGraph.addModule(ClassGraph.java:135)
at com.ibm.ws.classloader.ClassLoaderManager.initialize(ClassLoaderManager.java:192)
at com.ibm.ws.classloader.ClassLoaderManager.<init>(ClassLoaderManager.java:155)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:699)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:918)
... 3 more

[12/28/11 9:25:02:668 EST] 0000000a TCPChannel A TCPC0001I: TCP Channel TCP_1 is listening on host * (IPv4) port 9060.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Websphere Startup Issues
 
Similar Threads
Service specific error 10
Problem while starting websphere portalserver 6.1.0.1 (log file attached)
Problem while starting websphere portalserver 6.0 (log file attached)
Portal Server v6.0 Initialization Problem
struts2.0 application issues