This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Struts and the fly likes Why my servlet application folder showing false running status on Tomcat server? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Why my servlet application folder showing false running status on Tomcat server?" Watch "Why my servlet application folder showing false running status on Tomcat server?" New topic
Author

Why my servlet application folder showing false running status on Tomcat server?

sandeep kumar thommandru
Greenhorn

Joined: Dec 30, 2011
Posts: 21
hi every one

can you please suggest me..

my application folder name is "serv-exam" and it was deployed in Tomca5.5\webapps folder
when i start the server and navigated to the manager there i found the false status for this folder..



[Thumbnail for tomcatapp1.JPG]


[Thumbnail for tomcatapp2.JPG]

sandeep kumar thommandru
Greenhorn

Joined: Dec 30, 2011
Posts: 21
my web.xml file:

<web-app>
<servlet>
<servlet-name>serv1</servlet-name>
<servlet-class>RD1</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>serv1</servlet-name>
<url-pattern>/RD1</url-pattern>
</servlet-mapping>
servlet>
<servlet-name>serv2</servlet-name>
<servlet-class>RD2</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>serv2</servlet-name>
<url-pattern>/RD2</url-pattern>
</servlet-mapping>
<servlet>
<servlet-name>ex</servlet-name>
<servlet-class>Exp11</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>ex</servlet-name>
<url-pattern>/Exp11</url-pattern>
</servlet-mapping>
servlet>
<servlet-name>exam</servlet-name>
<servlet-class>sexam2</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>exam</servlet-name>
<url-pattern>/sexam2</url-pattern>
</servlet-mapping>
<servlet>
<servlet-name>alpha</servlet-name>
<servlet-class>Alpha11</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>alpha</servlet-name>
<url-pattern>/Alpha11</url-pattern>
</servlet-mapping>
servlet>
<servlet-name>ex1</servlet-name>
<servlet-class>ExpDB4</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>ex1</servlet-name>
<url-pattern>/ExpDB4</url-pattern>
</servlet-mapping>
</web-app>
Tim Moores
Rancher

Joined: Sep 21, 2011
Posts: 2408
Are there any exceptions in the log files? What makes you say that the status is incorrect - does the app actually run?
sandeep kumar thommandru
Greenhorn

Joined: Dec 30, 2011
Posts: 21
dont know tim..
dats why i posted..
whenever a war file is deployed.. it is showing that status..
Tim Moores
Rancher

Joined: Sep 21, 2011
Posts: 2408
So you haven't actually tried accessing http://localhost:8080/serv-exam ? Why not? But the odds are it doesn't run. Check the log files for exceptions; there will almost certainly be at least one.
asif aftab
Greenhorn

Joined: Aug 15, 2013
Posts: 1
Tim Moores wrote:So you haven't actually tried accessing http://localhost:8080/serv-exam ? Why not? But the odds are it doesn't run. Check the log files for exceptions; there will almost certainly be at least one.

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: taglib definition not consistent
with specification version
at org.apache.catalina.startup.TaglibLocationRule.begin(WebRuleSet.java:
1274)
at org.apache.tomcat.util.digester.Digester.startElement(Digester.java:1
276)
... 30 more

Aug 17, 2013 9:02:41 AM org.apache.catalina.startup.ContextConfig parseWebXml
SEVERE: Occurred at line 21 column 10
Aug 17, 2013 9:02:41 AM org.apache.catalina.startup.ContextConfig configureStart

SEVERE: Marking this application unavailable due to previous error(s)

and my project showing false in application manager as running state
please help me to resolve the issue

index.jsp


<%@ taglib uri="/struts-tags" prefix="s" %>

<s:form action="product">
<s:textfield name="id" label="Product Id" ></s:textfield>
<s:textfield name="name" label="Product Name" ></s:textfield>
<s:textfield name="price" label="Product Price" ></s:textfield>
<s:submit value="save" ></s:submit>
</s:form>

web.xml


<?xml version="1.0" encoding="UTF-8" ?>

<web-app>

<filter>
<filter-name>struts2</filter-name>
<filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
</filter>

<filter-mapping>
<filter-name>struts2</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

</web-app>


Product.java


package com.javatpoint;

public class Product
{
private int id;
private String name;
private float price;

public int getId()
{
return id;
}
public void setId(int id)
{
this.id=id;
}
public String getName()
{
return name;
}
public void setName(String name)
{
this.name=name;
}
public float getPrice()
{
return price;
}
public void setPrice(float pr)
{
price=pr;
}
public String execute()
{
return "success";
}
}

struts.xml


<?xml version="1.0" encoding="UTF-8" ?>

<!DOCTYPE struts PUBLIC"-//Apache Software Foundation//DTD Struts Configuration 2.1//EN" "http://struts.apache.org./dtds/struts-2.1.dtd">

<struts>

<package name="default" extends="struts-default">
<action name="product" class="com.javatpoint.Product" >
<result name="success" > Welcome.jsp</result>
</action>
</package>



</struts>

welcome.jsp

each and every time error is http 404 resource not found
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Why my servlet application folder showing false running status on Tomcat server?