File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Other Application Frameworks and the fly likes Problem with Views in Eclipse RCP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Make it so: Java DB Connections & Transactions this week in the JDBC forum!
JavaRanch » Java Forums » Frameworks » Other Application Frameworks
Bookmark "Problem with Views in Eclipse RCP" Watch "Problem with Views in Eclipse RCP" New topic

Problem with Views in Eclipse RCP

Emad Heydari Beni

Joined: Jan 05, 2012
Posts: 3
My system information:
Ubuntu 11.10
64-bit Architecture
Eclipse (Indigo Service Release 1)
Using jNetPcap wrapper to read network pcap-formatted offline files.

Step by step to face a problem:
  • Open the Eclipse, make new Plug-in Project with "Rich Client Platform" check box enabled. (Default template: RCP application with a view)
  • Right-click on the project and click properties; then go to the Java Build Path to add the jNetPcap Jar file. Add the Jar file.
  • Take a look at the example of reading offline files using jNetPcap which is posted on its website.
  • Open the default view to add some codes. (file: By default, it has a TableViewer with 3 inputs.
  • I add my codes to this method of this class:

  • Continue: Then, I run the project as Eclipse Application and I see this Error stack in console tab of my Eclipse:

    Help: Please help me, let me know if I missed any part in my project.
    I should mention that I can read Offline pcap files in normal Java Project.
    Source file: - MyRCProject.tar
    Emad Heydari Beni

    Joined: Jan 05, 2012
    Posts: 3
    [Problem is solved]

    I have done two steps to fix the exceptions:

  • According to FAQ, I've done some further steps
  • Then, I found out that I forgot to copy to the /usr/lib

  • Use this command in Ubuntu terminal:
    I agree. Here's the link:
    subject: Problem with Views in Eclipse RCP
    It's not a secret anymore!