File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes problem in starting tomcat with eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "problem in starting tomcat with eclipse" Watch "problem in starting tomcat with eclipse" New topic
Author

problem in starting tomcat with eclipse

Punit Jain
Ranch Hand

Joined: Aug 20, 2011
Posts: 1000
    
    2
Hello everyone,
i have installed tomcat6 in my Ubuntu system using this command [sudo apt-get install apache2] for lamp server, and i successfully started this.
now i have install eclipse and download tomcat6, and reference the downloaded tomcat6 into my eclipse, but here i am not able to start my tomcat6, it's giving me error that port is already in use, but i have also changed port from 8080 to 8081 but it still giving me error, error is:

"Port 8005 required by Tomcat v6.0 Server at localhost is already in use. The server may already be running in another process, or a system process may be using the port. To start this server you will need to stop the other process or change the port number(s)."

and here is my server.xml (after changing port from 8080 to 8081)

server.xml



can anyone help me in this please..




chandu ravalpu
Greenhorn

Joined: Jan 11, 2012
Posts: 7
Hi

May be other server running outside or in any other applications

I face this problem ,I cleared it by stoping server which is running in another workspace.

May be this solution will work for you
Punit Jain
Ranch Hand

Joined: Aug 20, 2011
Posts: 1000
    
    2
but i removed all other servers, and every stuff from my system, and install eclipse again and configure tomcat, but still the problem is same, even i installed it on my friend's system, in that also i m facing the same problem...
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem in starting tomcat with eclipse