Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Ant + Weblogic + EJb on Eclipse - UnsupportedClassVersionError

 
Akhilesh Trivedi
Ranch Hand
Posts: 1599
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am on WebLogic 10.0

My JAVA_HOME is set to JDK 1.4

The same I have configured for the project properties -->java Compiler -->JDK Compliance

I am compiling an EJB on ant script.

Ant is also configured to run on Excution JRE as 1.4.

And it gives me following error.


Problem is at the line:


Whats wrong? I have tried switching between versions, and at a point I got a jar out! but when I deployed it, I ended up with an error on the server.
 
German Gonzalez-Morris
Ranch Hand
Posts: 263
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
java.lang.UnsupportedClassVersionError: weblogic/utils/compiler/Tool (Unsupported major.minor version 49.0)
is when you are using diff JDK version.

for WLS 10.0 you need to use JDK 1.5 and not 1.4

 
anandraj tadkal
Ranch Hand
Posts: 98
Oracle Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Change the JAVA_HOME to the JDK 1.5

Cheers,
Anandraj
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic