Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

I am getting following error

 
Mano haran
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Parsing of JSP File '/welcome.jsp' failed:
--------------------------------------------------------------------------------
/welcome.jsp(3): Error in using tag library uri='/WEB-INF/struts-html.tld' prefix='html': The Tag class 'org.apache.struts.taglib.html.FormTag' has no setter method corresponding to TLD declared attribute 'name', (JSP 1.1 spec, 5.4.1)
probably occurred due to an error in /welcome.jsp line 3:
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
 
Raghavan Muthu
Ranch Hand
Posts: 3381
Mac MySQL Database Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
have you configured your taglib-uri and tablib-location in web.xml?
 
Mano haran
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Raghavan Muthu:
have you configured your taglib-uri and tablib-location in web.xml?
 
Mano haran
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Raghavan Muthu:
have you configured your taglib-uri and tablib-location in web.xml?


yes i have configured web.xml file, as follows

<!-- Struts Tag Library Descriptors -->
<taglib>
<taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>/WEB-INF/struts-html.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-html.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>/WEB-INF/struts-logic.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
</taglib>

but still now i am getting this error.
 
Raghavan Muthu
Ranch Hand
Posts: 3381
Mac MySQL Database Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just check for struts.jar being same in both the development and deployment environments.

Which App/Web server you use? Check and keep the same struts.jar file in the deployment location as well. That might be one of the reasons.

Check this url
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In later versions of Struts, the name and type attribute of the <html:form> tag have been deprecated. Just remove these attributes from your <html:form> tag. They are unnecessary because both the name and typr are already defined in the struts-config.xml file.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic