This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Struts and the fly likes Using struts2tags select box is getting enabled soon after getting populated. Please help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Using struts2tags select box is getting enabled soon after getting populated. Please help" Watch "Using struts2tags select box is getting enabled soon after getting populated. Please help" New topic
Author

Using struts2tags select box is getting enabled soon after getting populated. Please help

Venkat Samanthula
Greenhorn

Joined: Oct 13, 2008
Posts: 1
Hi Friends,

I have added two select box in a jsp using struts 2 tags and on selecting the Location , i am populating the Model select box automatically from database. Model is populated with right values from database but getting enabled. My main task is to populate and disable the Model select box permanently when i choose Location. Here is my code


<tr>
<td class="tdLabel tdSized">Location:</td>
<td><s:autocompleter required="true"
notifyTopics="/changed" theme="ajax" id="Location"
keyName="Location" forceValidOption="true"
href="locationlist.do" cssStyle="width: 120px;"
autoComplete="true" formId="randForm"/></td>
</tr>

<tr>
<td class="tdLabel tdSized">Model:</td>
<td><s:autocompleter theme="ajax" id="Model"
keyName="Model" href="modellist.do" forceValidOption="true"
cssStyle="width: 120px;" autoComplete="false" disabled="true"
formId="randForm" /></td>
</tr>

Even thought i place disabled = "true", Model is getting disabled untill no values are populated. Once if there is a Model for a particular Location then Model is populated and getting enabled. Please help me with this.

Thanks,
Venkat
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Using struts2tags select box is getting enabled soon after getting populated. Please help