wood burning stoves 2.0*
The moose likes BEA/Weblogic and the fly likes Error when deploying WS generated from WSDL in Netbeans (wls1035) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Error when deploying WS generated from WSDL in Netbeans (wls1035)" Watch "Error when deploying WS generated from WSDL in Netbeans (wls1035)" New topic
Author

Error when deploying WS generated from WSDL in Netbeans (wls1035)

Schizzle Nizzle
Greenhorn

Joined: Jan 09, 2012
Posts: 1
Netbeans 7.0.1
wls1035
Java EE5

In Netbeans I have created a Web Application project, and then created a Web Service from a WSDL contract in that project. When I try to deploy the project I get the following exception from Weblogic:

<Jan 9, 2012 10:54:19 AM EST> <Error> <HTTP> <BEA-101216> <Servlet: "test.testws2.NewWebServiceFromWSDL" failed to preload on startup in Web application: "web".
java.lang.Error: Undefined operation name beaInvoke
at com.sun.xml.ws.model.JavaMethodImpl.freeze(JavaMethodImpl.java:327)
at com.sun.xml.ws.model.AbstractSEIModelImpl.freeze(AbstractSEIModelImpl.java:104)
at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:289)
at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:363)
at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:202)


If I delete this service and create a new web service from a Java Class (not based on a WSDL) I am able to deploy it successfully. However, services I create based on a WSDL contract however fail to deploy to Weblogic with the above exception.

Any idea what I'm doing wrong?
Gary Marshall
Ranch Hand

Joined: Feb 19, 2007
Posts: 121
I'm having the same issue.

Any takers on this one?

thanks


G
Gary Marshall
Ranch Hand

Joined: Feb 19, 2007
Posts: 121
Ok. I just fixed this. Shoulda known this one.... I went into the Weblogic console app / deployments and deleted the module that was there and installed a new one using Weblogic's install dialog.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error when deploying WS generated from WSDL in Netbeans (wls1035)
 
Similar Threads
DeploymentException while creating top down web service
NetBeans JAX-WS WSDL
error deploying ejb web service to weblogic, built using netbeans 6.8
Error when deploying Web service to Axis runtime
How to Produce a WSDL file when using JAXWS Approach .