File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Redirection from http to https: blank page opens Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Redirection from http to https: blank page opens" Watch "Redirection from http to https: blank page opens" New topic
Author

Redirection from http to https: blank page opens

prerna mishra
Greenhorn

Joined: Jan 11, 2012
Posts: 2
hi all,
i am using tomcat 5.5 as web server and i want to redirect the http pages to https automatically.for that i have changed server.xml and web.xml file in the following manner:
server.xml file: i just uncommented the code below-
<!-- Define a SSL HTTP/1.1 Connector on port 8443 -->
<!--
<Connector port="8443" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" keystoreFile="conf/keystore" keystorePass="changeit"
/>
-->
web.xml file: i wrote the code below
<security-constraint>
<web-resource-collection>
<web-resource-name>all-except-attachments</web-resource-name>
<url-pattern>/*</url-pattern>
</web-resource-collection>
<user-data-constraint>
<transport-guarantee>Confidential</transport-guarantee>
</user-data-constraint>
</security-constraint>

Everything is going fine but the problem is when i send http request IE asks for security exception and after comfirming it redirected to https but page contents are not visible and when i refreshed the page, page is displayed instantly.I tried to figure out the problem but in vain.
Actually same settings i did for my local server tomcat 6.0.16. n there was no such problem. but when i applied that setting to the company server tomcat 5.5 then it is having this problem.
Please HELP!
prerna mishra
Greenhorn

Joined: Jan 11, 2012
Posts: 2
No Replies..
Please tell me if there is some kind of mistake i am doing because everything runs fine on my local server but when it comes to intranet server it is showing http & https page fine but http to https redirection shows page only after refresh..
Any Clues or directions ...
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Redirection from http to https: blank page opens