This week's book giveaway is in the Android forum.
We're giving away four copies of Head First Android and have Dawn & David Griffiths on-line!
See this thread for details.
The moose likes Web Services and the fly likes WSSecurity, MTOM and TIBCO 5.6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "WSSecurity, MTOM and TIBCO 5.6" Watch "WSSecurity, MTOM and TIBCO 5.6" New topic
Author

WSSecurity, MTOM and TIBCO 5.6

Luis Gmz
Greenhorn

Joined: Jan 11, 2012
Posts: 1
Hi to everybody,
I'm developing webservices in a project with TIBCO 5.6 as ESB, using tibco designer 5.6.
XML are signed, using X509 certificates.
For optimization purposes, we have to change one of our webservices, using MTOM.

Stripped XSD containing Datatype:



WSDL (forget * in namespaces, just for security)


Launching request from a CXF client, or from a soapUI, give me the same error inside TIBCO process:
This is part of the request (copy from :


Error trace:






Exception:


I've tried add this lines to designer.tra:

#11/1/2012
java.property.com.tibco.plugin.soap.trace.inbound=true
java.property.com.tibco.plugin.soap.trace.filename=D:/temp/soap.txt
java.property.com.tibco.plugin.soap.trace.outbound=true
java.property.com.tibco.plugin.soap.trace.pretty=true
java.property.com.tibco.plugin.soap.trace.stdout=true
java.property.com.tibco.plugin.soap.SOAPSendReceiveActivity.NoOutputValidation=true
java.property.com.tibco.plugin.soap.SOAPSendReceiveActivity.NoInputValidation=true


But still the same error.

¿Any help?
 
wood burning stoves
 
subject: WSSecurity, MTOM and TIBCO 5.6
 
jQuery in Action, 3rd edition