• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Compatibility between Struts 2.0.6 and Tomcat 6.0.13

 
Yogaraj Khanal
Ranch Hand
Posts: 54
Eclipse IDE Mac OS X Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have used the combination of Tomcat 6.0.13 and Struts jar 1.3.8 to run the Struts application.
But I couldn't run the same application with the 2.0.6 Struts jar.
Please mail me if you guys have done so successfully or have any kind of similar problems.
Raj
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The differences between Struts 1 and Struts 2 are significant enough that you can't just replace the Struts 1.3.8 jar file with the Struts 2.0.6 Jar file and expect your application to run regardless of which version of Tomcat you're using.

If you want the application to work, you must migrate it to a Struts 2 application, which involves changing some code. See the migration guide for more information.

Once you have a properly written Struts 2 application, there's no reason it won't run on Tomcat 6.
[ June 06, 2007: Message edited by: Merrill Higginson ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic