Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

request does not pass to action

 
Omar Mohaidat
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dears,

I want to login system using my username and password, the system redirect me to error page, then I have to enter username and password again to login successfully. every day when i want to use this system I have to enter my username and password twice. i traced the code of this system. when i click on submit, there is a filter start working, then execute method start working in Action class.
My problem is in first login, doFilter method working fine but when doFilter finished the work, execute method in Action class do not run.

filter in web.xml:


Filter class is:


In all cases Exit doFilter() is printed out, even in first login. after that the execute method in Action class should start. but in first login; EXit doFilter() printed out and return error page. in second login; exit doFilter() printed out and then execute strart working.

And the strange thing, I tried to run the system from the server with same URL, it is working fine from first login.

any help?

 
Vicky Vijay
Ranch Hand
Posts: 125
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check your firewall settings..

Which security framework you are using.. ?? for your application
 
Omar Mohaidat
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Firewall is stopped but same issue.

I am using LDAP on WAS6.
 
Vicky Vijay
Ranch Hand
Posts: 125
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Check the following,

1. Is the Application and LDAP connection are in sync ?

2. Are you using your - 'system name' as the "username" for Application login ?

3. Is there any "BIND ERROR" in your LOG FILE ?



 
Omar Mohaidat
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Guru,

Thanks for your help, I am still investigating why this issue, I am using domain username and no errors in log file, but i found other layer used by this system, after submit username and password, the filter start running and then there is spring framework, in the configuration file I found this:


In struts configuration file:



and in web.xml, there is this listener:


now, the problem exactly, after first submit; com.cms.page.actions.ViewHomePageAction class does not work at all, after second submit this class is working fine.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic