aspose file tools*
The moose likes Other JSE/JEE APIs and the fly likes Java mail problem in IE Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Other JSE/JEE APIs
Bookmark "Java mail problem in IE" Watch "Java mail problem in IE" New topic
Author

Java mail problem in IE

mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

Hi i have implemented some code to send mail in java it is working in chrome and firrfox. But in IE it is showing empty page my code is



It is called in my servlet like this


Please help me with this
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10519
    
    9

What do you get on the printStackTrace()?
Also, I hope you realize, the JOptionPane.showXXXDialog will be executed on the server side and your client will never see it.

Moving to a more appropriate forum


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

I IE it is showing a blank page with same URL as chrome and firefox. But in chrome and firefox showing the page correctly. Is there any problem with IE browser session closing
FYI : My page taking nearly 30 sec to display next page in chrome and firefox
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18886
    
    8

Maneesh Godbole wrote:What do you get on the printStackTrace()?
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

Nothing in my printStackTrace(). the problem is with IE 9 browser only(i have to test lower versions of IE). am i need to change some settings in my IE
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18886
    
    8

We are asking because we suspect that your server code (what you posted) is throwing an exception, and that different browsers are interpreting a combination of partial HTML code plus a 500-level error code differently. You never have to configure the browser to receive normal HTML responses, so it looks like you aren't sending a normal HTML response.

So there are several things you should be looking into. Does your server code throw an exception, or is the e-mail sent successfully? Are you sending any HTML at all as your response? What is the response code sent by your code: 200 for normal, or something else? You'll notice that all of this is at the server side; the browser should have nothing to do with it.
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

There are no errors the mail is sending well wheen i use chorm or firefox but in IE it is not showing any error and mail also not going.
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18886
    
    8

Let's clarify. You casually mentioned a "servlet" and we are therefore assuming that IE, Firefox, and so on are browsers which are sending the request to a server, which is where the servlet runs. Is that correct? Because you are continually going on about the browsers, as if this code is perhaps in an applet or something like that.
mallikarjun dontamsetti
Ranch Hand

Joined: Mar 18, 2011
Posts: 244

When i tried in IE9 my welogic server log file show me this error
<Warning> <Socket> <BEA-000449> <Closing socket as no data read from it during the configured idle timeout of 5 secs>
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Java mail problem in IE