aspose file tools*
The moose likes Programmer Certification (SCJP/OCPJP) and the fly likes Mule standalone: Failed to read schema document Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Programmer Certification (SCJP/OCPJP)
Reply locked New topic
Author

Mule standalone: Failed to read schema document "AMQP issue"

Achraf Charafi
Greenhorn

Joined: Jan 30, 2012
Posts: 4
Hi

I'm trying to build a little web service demo with:

cxf 2.2.6
Mule 3.2.0
Maven 3
spring 3.0.6.RELEASE
rabbitmq (amqp-client) 2.3.1
A simple web service that takes an object person and then sends it via RabbitMq brocker to an othe application. this application returnes back the person's gender (String) also via RabbitMq to the Web service. then my Web service gives it back via Http.
I deploy my web service via Mule server: put the .war file into apps folder in mule installation and run mul standalone 3.2.0 via command prompt.
Now the pb is that I have an exception when Mule try to deploy it :

" Failed to read schema document 'http://www.mulesoft.org/schema/mule/amqp/3.1/mule-amqp.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema> "

What gets me confused is that I'm using the same schema I have been using before which works on other web service with Mule running under Jboss.

My configuration file is the following:

*************************************************************************************************************************

<?xml version="1.0" encoding="UTF-8"?>

<mule xmlns="http://www.mulesoft.org/schema/mule/core" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:http="http://www.mulesoft.org/schema/mule/http" xmlns:file="http://www.mulesoft.org/schema/mule/file"
xmlns:amqp="http://www.mulesoft.org/schema/mule/amqp" xmlns:cxf="http://www.mulesoft.org/schema/mule/cxf"
xmlns:stdio="http://www.mulesoft.org/schema/mule/stdio" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:http-conf="http://cxf.apache.org/transports/http/configuration"
xmlns:spring="http://www.springframework.org/schema/beans"
xmlns:context="http://www.springframework.org/schema/context"
xmlns:mulexml="http://www.mulesoft.org/schema/mule/xml" xmlns:vm="http://www.mulesoft.org/schema/mule/vm"
xsi:schemaLocation="
http://www.mulesoft.org/schema/mule/core http://www.mulesoft.org/schema/mule/core/3.1/mule.xsd
http://www.mulesoft.org/schema/mule/http http://www.mulesoft.org/schema/mule/http/3.1/mule-http.xsd
http://www.mulesoft.org/schema/mule/file http://www.mulesoft.org/schema/mule/file/3.1/mule-file.xsd
http://www.mulesoft.org/schema/mule/amqp http://www.mulesoft.org/schema/mule/amqp/3.1/mule-amqp.xsd
http://www.mulesource.org/schema/mule/soap http://www.mulesoft.org/schema/mule/soap/3.0/mule-soap.xsd
http://www.mulesoft.org/schema/mule/cxf http://www.mulesoft.org/schema/mule/cxf/3.1/mule-cxf.xsd
http://www.mulesoft.org/schema/mule/stdio http://www.mulesoft.org/schema/mule/stdio/3.1/mule-stdio.xsd
http://www.mulesoft.org/schema/mule/vm http://www.mulesoft.org/schema/mule/vm/3.1/mule-vm.xsd
http://cxf.apache.org/transports/http/configuration http://cxf.apache.org/schemas/configuration/http-conf.xsd
http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-3.0.xsd
http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
http://www.mulesoft.org/schema/mule/xml http://www.mulesoft.org/schema/mule/xml/3.1/mule-xml.xsd
">

<spring:beans>
<spring:import resource="application-context.xml" />
</spring:beans>

<amqp:connector name="amqpMbssConnector"
virtualHost="/"
host="localhost"
port="5672"
username="guest"
password="guest">
</amqp:connector>
<model name="PersonServices">
<service name="PersonTypeService">
<inbound>
<http:inbound-endpoint address="http://localhost:8080/MuleWS/personService" exchange-pattern="request-response">
<cxf:jaxws-service serviceClass="ws.IPersonService" />
</http:inbound-endpoint>
</inbound>
<component>
<spring-object bean="personService" />
</component>
<outbound>
<filtering-router>
<amqp:outbound-endpoint routingKey="test"
exchange-pattern="request-response"
exchangeName="test"
connector-ref="amqpMbssConnector">
</amqp:outbound-endpoint>
</filtering-router>
</outbound>
</service>
</model>
</mule>
*************************************************************************************************************************

My application-context.xml is the following:

**********************************************************************
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:jaxws="http://cxf.apache.org/jaxws"
xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd http://cxf.apache.org/jaxws http://cxf.apache.org/schemas/jaxws.xsd">
<import resource="classpath:META-INF/cxf/cxf.xml" />
<import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
<import resource="classpath:META-INF/cxf/cxf-servlet.xml" />
<!-- Spring manage ServiceBean -->
<bean id="personServ" class="ws.PersonServiceImpl"/>
<!-- JAX-WS Service Endpoint -->
<jaxws:endpoint id="personService" implementor="#personServ" address="/personService" />
</beans>

**********************************************************************

I appreciate if any one could help me getting this demo working correctly.

thanks.
Anayonkar Shivalkar
Bartender

Joined: Dec 08, 2010
Posts: 1505
    
    5

Hi achraf bio achraf,

Welcome to coderanch!

I don't know a thing about web services, but I think that this topic should belong here


Regards,
Anayonkar Shivalkar (SCJP, SCWCD, OCMJD, OCEEJBD)
Achraf Charafi
Greenhorn

Joined: Jan 30, 2012
Posts: 4
Thanks a lot. I'v probably posted the issue at the wrong place hhhh ;)

I'll try to look over there.

thanks.
Mohamed Sanaulla
Saloon Keeper

Joined: Sep 08, 2007
Posts: 3068
    
  33

achraf bio achraf wrote:Thanks a lot. I'v probably posted the issue at the wrong place hhhh ;)

I'll try to look over there.

thanks.


Posted here as well. Please in future CarefullyChooseOneForum. I would lock this thread.


Mohamed Sanaulla | My Blog
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Mule standalone: Failed to read schema document "AMQP issue"