This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Struts and the fly likes Getting HTTP Status - 500 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Getting HTTP Status - 500" Watch "Getting HTTP Status - 500" New topic
Author

Getting HTTP Status - 500

Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Hello All,
I'm using Tomcat 6.0 ,J2EE 1.4 and Struts 1.2.7. I installed struts, had set the classpaths accordingly and started Tomcat to test the Struts. I copied struts-blank.war into WebApps in Tomcat installation and in brower gave
after starting the Tomcat server.

I got an exception with HTTP Status Code : 500, indicating some Unexpected server error. I have copied the log below :


Jul 12, 2007 8:55:07 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet action threw exception
javax.servlet.ServletException: javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZLjava/lang/String;ZZLjava/lang/String;Ljava/lang/String V
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:274)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)
at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:469)
at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:403)
at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1063)
at org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:263)
at org.apache.struts.action.RequestProcessor.internalModuleRelativeForward(RequestProcessor.java:1001)
at org.apache.struts.tiles.TilesRequestProcessor.internalModuleRelativeForward(TilesRequestProcessor.java:345)
at org.apache.struts.action.RequestProcessor.processForward(RequestProcessor.java:560)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:209)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1194)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:747)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:228)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
at java.lang.Thread.run(Thread.java:595)



I didn't understand anything from this log, except that service() method failed.

Can anyone let me know, what blunder I'm doing here?

Thanks in advance.
Zip Ped
Ranch Hand

Joined: Jul 26, 2005
Posts: 336
Did you try the url without the Welcome.do part?
Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Hi Kailash,

I just even tried http://localhost:8080/struts-blank/ ..but still I'm getting the same error. Any thoughts about this.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9912
    
158

Which version of Java are you using?


[My Blog] [JavaRanch Journal]
Merrill Higginson
Ranch Hand

Joined: Feb 15, 2005
Posts: 4864
What this message is telling you is that the Struts ActionServlet failed in performing its init() method. The most likely reasons for this are problems in parsing your struts-config.xml file, or bad information in your web.xml file. There should be more specific information on what went wrong in Tomcat's System Out log.


Merrill
Consultant, Sima Solutions
Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Hi All,
It was a quite some time I logged into this site. Things are working fine now. Thanks to you all for giving me valuable information.
Bala Gowda
Greenhorn

Joined: Aug 06, 2007
Posts: 1
Ravi,
How did you solved the problem. I am getting similar problem. I am using apache-tomcat-6.0.13, jdk 1.5.0_10 and struts 2.0.5.

Thanks
Bala
Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Bala,

Fresh re-installation worked fine for me
 
wood burning stoves
 
subject: Getting HTTP Status - 500
 
Similar Threads
Unable to translate jsp with struts-html taglib
JBoss 5.1 throwing error for missing jsp files in /WEB-INF folder
javax.servlet.jsp.JspException: Cannot create rewrite URL: java.net.MalformedURLException:
Struts JSP exception
javax.servlet.jsp.JspException in Application