This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Tomcat and the fly likes eclipse sts cannot start tomcat: ports already in use Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "eclipse sts cannot start tomcat: ports already in use" Watch "eclipse sts cannot start tomcat: ports already in use" New topic
Author

eclipse sts cannot start tomcat: ports already in use

Vyacheslav Sakhno
Greenhorn

Joined: Dec 30, 2011
Posts: 1
Tested eclipse indigo, STS 2.5.2, STS 2.8.0, STS 2.8.5. Tomcat 6, Tomcat 7.

Tomcat startup hangs at 23%(displayed at right bottom side of eclipse windows/screen). This magic number is always the same. After about 20 seconds at hanged state error occurs. Error info is "ports are already in use".

There is no Tomcat already started in system. No ports with specified numbers appear in netstat.

Changing port numbers does not help anything.

Changing/reinstalling eclipse,STS,tomcat, downloading fresh tomcat zip changes nothing. Deleting workspace and C:/Project/.metadata and stuff - all directories used by fresh install of STS, so deleting them does not help too.

And interesting history aspect: i've used STS 2.8.2 for 2 weeks before this error occured. Reinstall won't fix anything. After that i was able to use STS 2.5.2 for a month. And the same error occured for 2.8.2. But i delete all its files and reinstall again does not fix anything.

Reboot does not help.

Have no any other working with tomcat version of eclipse/STS.

Any help is appreciated.

my os is windows 7. In Virtualbox XP everything is fine. And other Windows 7 guys say it works too on their PCs.

http://stackoverflow.com/questions/9096490/eclipse-sts-cannot-start-tomcat-ports-already-in-use
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: eclipse sts cannot start tomcat: ports already in use
 
Similar Threads
Tomcat Startup problem. Server Tomcat v6.0 Server at localhost was unable to start within 45 seconds
Error in running tomcat
How to add tomcat 5.5.27 server in eclipse europa 3.3.2
Error in running tomcat
Running SpringTravel sample application for STS 2.3.2 & eclipse-rcp-galileo-SR2-win32