This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to initialize Struts ActionServlet due to an unexpected exception

 
Ronald Mee
Greenhorn
Posts: 15
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Unable to initialize Struts ActionServlet due to an unexpected exception or error thrown, so marking the servlet as unavailable. Most likely, this is due to an incorrect or missing library dependency.

I got the above error..when i try to run a struts application..
anyone have any idea what could be the problem?
 
Herman Schelti
Ranch Hand
Posts: 387
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Ronald,

most likely you will have to add this missing library.

(or else show use the real errormessage, sometimes that helps.)

Herman
 
Ronald Mee
Greenhorn
Posts: 15
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the previous problem is being resolved


now i am having another problem

when i try to run the .do file i got this error..

java.lang.UnsupportedClassVersionError: Bad version number in .class file


any idea?
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This error occurs when there is a problem with Java SDK versions. For example, it could occur if you had compiled the class under SDK 1.5 or 1.6, and then tried to run it in an Application Server that is running under SDK 1.4.

You can still use the higher release compiler as long as you specify

-target 1.4

as a compile option.
 
Gayan Herath
Greenhorn
Posts: 7
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi ronald,
How did you resolved the previous problem? I am having the same problem.

Gayan Herath


Ronald Mee wrote:the previous problem is being resolved


now i am having another problem

when i try to run the .do file i got this error..

java.lang.UnsupportedClassVersionError: Bad version number in .class file


any idea?
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic