wood burning stoves 2.0*
The moose likes Struts and the fly likes Redirection not working in QA Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Redirection not working in QA" Watch "Redirection not working in QA" New topic
Author

Redirection not working in QA

Paras Jain
Ranch Hand

Joined: Feb 26, 2005
Posts: 137
Hi,

I trying to redirect some of the legacy links in aspx to servlet in my struts application.
I am doing something like this in my web.xml


From the browser when I call
http://localhost:8080/MyApp/abc.aspx
the redirection works and the servlet is hit
but when we deploy the application on QA or production the redirection does not work. It says cannot find resource or something like that.
Please not that
a) We are using the same version of tomcat in my local and in QA
b) This URL is also called from one flash application embedded in JSP. I have checked the servletcontext and context path for both local version and QA version at runtime. They are the same.

What could be the possible reason for that.

Thanks in advance,
Paras


Paras Jain
SCJP 5.0
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60794
    
  65

Originally posted by Paras Jain:
It says cannot find resource or something like that.


This is not a particularly helpful description of the problem.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Paras Jain
Ranch Hand

Joined: Feb 26, 2005
Posts: 137
Hi,
Thanks for the reply. And sorry to confuse you. Here is the full problem description which i see on browser

The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /MyApp/abc.aspx

[ July 21, 2007: Message edited by: Paras Jain ]
 
wood burning stoves
 
subject: Redirection not working in QA
 
Similar Threads
extra path attempts yield 404s
invoking servlets differently
Deploying the application
Tapestry and Tomcat
How do I start a web application on an xhtml page?