• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Redirection not working in QA

 
Paras Jain
Ranch Hand
Posts: 138
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I trying to redirect some of the legacy links in aspx to servlet in my struts application.
I am doing something like this in my web.xml


From the browser when I call
http://localhost:8080/MyApp/abc.aspx
the redirection works and the servlet is hit
but when we deploy the application on QA or production the redirection does not work. It says cannot find resource or something like that.
Please not that
a) We are using the same version of tomcat in my local and in QA
b) This URL is also called from one flash application embedded in JSP. I have checked the servletcontext and context path for both local version and QA version at runtime. They are the same.

What could be the possible reason for that.

Thanks in advance,
Paras
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64830
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Paras Jain:
It says cannot find resource or something like that.


This is not a particularly helpful description of the problem.
 
Paras Jain
Ranch Hand
Posts: 138
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Thanks for the reply. And sorry to confuse you. Here is the full problem description which i see on browser

The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /MyApp/abc.aspx

[ July 21, 2007: Message edited by: Paras Jain ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic