aspose file tools*
The moose likes BEA/Weblogic and the fly likes user creation in weblogic 8.1 and weblogic 10.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "user creation in weblogic 8.1 and weblogic 10.3" Watch "user creation in weblogic 8.1 and weblogic 10.3" New topic
Author

user creation in weblogic 8.1 and weblogic 10.3

Praveena Paruchuru
Greenhorn

Joined: Dec 10, 2009
Posts: 6
Hi

We have our application deployed in weblogic 8.1 and it works fine. I tried with deploying it on weblogic 10.3. It is failing with the error message cannot resovle role-name : ges_user.
I created the user ges_user as I did in weblogic 8.1. But it is throwing the error.

Please let me know if I have to do anything differently in weblogic 10.3 with respect user creation.

Entry in web.xml
<run-as>
<role-name>ges_user</role-name>
</run-as>
</servlet>



Entry in weblogic-ejb-jar.xml
<security-role-assignment>
<role-name>ges_user_group</role-name>
<principal-name>ges_user</principal-name>
</security-role-assignment>



Entry in ejb-jar.xml
<security-identity>
<run-as>
<role-name>ges_user_group</role-name>
</run-as>
</security-identity>
</message-driven>


Exception log:
caused by: weblogic.management.DeploymentException: Cannot resolve role-Name ges_user

at weblogic.servlet.security.internal.WebAppSecurity.getRunAsPrincipalName(WebAppSecurity.java:421)
at weblogic.servlet.internal.WebAppServletContext.registerServlets(WebAppServletContext.java:1454)
at weblogic.servlet.internal.WebAppServletContext.registerServlets(WebAppServletContext.java:1407)
at weblogic.servlet.internal.WebAppServletContext.prepareFromDescriptors(WebAppServletContext.java:1185)
at weblogic.servlet.internal.WebAppServletContext.prepare(WebAppServletContext.java:1120)
at weblogic.servlet.internal.HttpServer.doPostContextInit(HttpServer.java:449)
at weblogic.servlet.internal.HttpServer.loadWebApp(HttpServer.java:424)
at weblogic.servlet.internal.WebAppModule.registerWebApp(WebAppModule.java:910)
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:364)


I tried creating the group ges_user_group and assinging the user ges_user. ges_user_group is added to the membership of administrators.
2. I tried creating the user ges_user and addign teh group Administrator. In weblogic 8.1 I haven't given any group to that user but it works.
3. I also tried creating teh user ges_user_group.

Thanks
Praveena
muralidhar vejendla
Greenhorn

Joined: Sep 11, 2011
Posts: 5
Hi ,

Its saying the Exception : not Resolving : " role-Name" but you mention the tags as ' role-name' .

try to Resolve by Replacing the role-Name ( may be in Deployment-plan ) into role-name.

send the Feedback ... how you resolve the Issue .


Thanks.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: user creation in weblogic 8.1 and weblogic 10.3