This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Spring and the fly likes NullPointerException running Spring in main() from DefaultListableBeanFactory Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Spring
Bookmark "NullPointerException running Spring in main() from DefaultListableBeanFactory" Watch "NullPointerException running Spring in main() from DefaultListableBeanFactory" New topic
Author

NullPointerException running Spring in main() from DefaultListableBeanFactory

Brian Mulholland
Ranch Hand

Joined: Mar 12, 2009
Posts: 61
So I have a spring webapp. Works fine. But our test classes, when run as main() apps are blowing up with the following exceptions:



NPE coming from here:


I've seen some posts online suggesting that this means the class loader is null. One recommended citing jars explicitly rather than using a directory. Another suggested that it was the load order of required jars. I don't see how either of these is my issue. I am running from Run As.. in Eclipse and have included all jars directly under the 'bootstrap' part of the classpath tab, just to make sure the jars were as early as possible.

Anyone know this issue?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: NullPointerException running Spring in main() from DefaultListableBeanFactory
 
Similar Threads
Error creating connetion from JNDI data sources
Problem running Spring Application
Problem in code
using ClassPathXmlApplicationContext to load beans
Error Log from Console