aspose file tools*
The moose likes Websphere and the fly likes WebSphere MIME type(video/mp4) under Windows Server 2003(IIS 7.5):video not playing iPhone/android Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "WebSphere MIME type(video/mp4) under Windows Server 2003(IIS 7.5):video not playing iPhone/android" Watch "WebSphere MIME type(video/mp4) under Windows Server 2003(IIS 7.5):video not playing iPhone/android" New topic
Author

WebSphere MIME type(video/mp4) under Windows Server 2003(IIS 7.5):video not playing iPhone/android

Sridip Banerjee
Greenhorn

Joined: Feb 20, 2012
Posts: 4
I am deploying a strut application in WebSphere that serves a MP4 file. As per the requirement I have added this MIME type (video/mp4) to the virtual host of my application(that was also being added at 'virtualhost.xml').

But when we are accessing that mp4 file from mobile browser(iphone/android)it cannot play the video although when we use desktop browser it is playing that mp4 video. By the way WebSphere is running on Windows Server 2003 (IIS 7.5) and I have also added video/mp4 MIME type in the IIS 7.5. Also restarted the server and all other necessary thing must be done.

I have done all the tweaking/experimenting possible(all suggestions from forums and IBM documentation) but was stuck in this for last 4 days. Can you please help me on this?

I am eagerly waiting for your valued response.
Sridip Banerjee
Greenhorn

Joined: Feb 20, 2012
Posts: 4
Someone please help...
Sridip Banerjee
Greenhorn

Joined: Feb 20, 2012
Posts: 4
I thought that this is a good forum...where people help each other!!! anyway still waiting....if somebody knows any solution to this...
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18651
    
    8

Have you already determined that those devices can play MP4 videos from other sites?
Sridip Banerjee
Greenhorn

Joined: Feb 20, 2012
Posts: 4
Thanks Paul for the reply.

Yes iphone or android both can play mp4. To test that I have written a simple application hosted by IIS that was being successfully played by iphone and android.

But when the WebSphere come into picture, the problem starts then. That mp4 was served by both IIS and WebSphere, as I have mentioned before that we are running WebSphere under a Windows Server 2008(IIS 7.5).

Please suggest what do you think might cause this issue. Thanks beforehand.

Vigneshwaran Thulasi Doss
Greenhorn

Joined: Sep 28, 2012
Posts: 1
I tried running the Websphere from Cent OS and no success. I think the mime type rendering is creating the problem. I'm using Websphere portal 7.0.0.2 . I also tried 6.1.5 but same issue. But if I play a video present at different server(src value is pointing to a video location online). Then video is getting rendered. I feel IBM needs to look at it.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WebSphere MIME type(video/mp4) under Windows Server 2003(IIS 7.5):video not playing iPhone/android