This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Web Services and the fly likes More about WSDL file Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "More about WSDL file" Watch "More about WSDL file" New topic
Author

More about WSDL file

Yogesh Gandhi
Ranch Hand

Joined: Dec 05, 2008
Posts: 212
How can I know, which version/prototype should I use for calling the web service.

I mean to say
I have a WSDL file,

Now i have been trying to call the web service using different editors/tools.
1. wsimport (java 1.4)
2. Jdev R2 (Not able to generate)
3. Jdev R3 (Getting PrivilegedActionException)
4. netbeans (getting Unsupported Content-Type: text/html Supported ones are: [text/xml])

Can someone please educate me how to identify what is the version that I need to use for Java and what is the prototype that server will support like JAX-RPC, or JAX-WS or any other if there.

 
It is sorta covered in the JavaRanch Style Guide.
 
subject: More about WSDL file