This week's book giveaway is in the OCPJP forum.
We're giving away four copies of OCA/OCP Java SE 7 Programmer I & II Study Guide and have Kathy Sierra & Bert Bates on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes JAAS Login using PropertiesUsers in JBoss 7.1 Final Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JAAS Login using PropertiesUsers in JBoss 7.1 Final" Watch "JAAS Login using PropertiesUsers in JBoss 7.1 Final" New topic
Author

JAAS Login using PropertiesUsers in JBoss 7.1 Final

Stefan Berger
Greenhorn

Joined: Sep 13, 2011
Posts: 4
Hello,
I'm having trouble setting up a login configuration using the "PropertiesUsers" login module in JBoss 7.1 Final. I have created 2 users in the " application-users.properties" file, one with the password in plain text and the other one was created with the add-user script. When I use the user with the plain password, I instantly get a "HTTP Status 403 - Access to the requested resource has been denied" message and the login dialog disappears, when I use the generated user, the login is also not successful but the login dialog stays. In both cases the exception below is thrown. Maybe I have missed something in the configuration, but I have run out of ideas and hope that someone can help me.



This is my configuration:

The security domain in the security domains section in the standalone.xml config file:


The application-users.properties file (The user "user" was generated by the add-user script from the JBoss bin directory):


jboss-web.xml:


web.xml:


 
 
subject: JAAS Login using PropertiesUsers in JBoss 7.1 Final