my dog learned polymorphism*
The moose likes Struts and the fly likes SSLExt, Tiles, Struts 1.3.5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "SSLExt, Tiles, Struts 1.3.5" Watch "SSLExt, Tiles, Struts 1.3.5" New topic
Author

SSLExt, Tiles, Struts 1.3.5

Patrick McDonogh
Ranch Hand

Joined: Oct 13, 2005
Posts: 89
Hi There All,

I apologise this is such a long problem but i dont know of another way to explain it.

I am having lots of problems getting SSLExt to work with Struts 1.3 and i am also using the tiles plugin.

I think the problem is that i am using tiles and have not configured something properly.

I followed the instructions at http://www.niallp.pwp.blueyonder.co.uk/sslext.html with how to do this but i am sure that i have to do something different when using tiles.

Does anyone know?

This is what i did.

I downloaded the struts13-sslext-command-1.0.jar as specified and added the org/nkp/struts13/sslext/sslext-chain-config.xml to the chainConfig in my web.xml

So it now reads
<init-param>
<param-name>chainConfig</param-name>
<param-value>
org/apache/struts/chain/chain-config.xml,org/nkp/struts13/sslext/sslext-chain-config.xml
</param-value>
</init-param>

I then modified my action-mappings elements as do:

<action-mappings type="org.apache.struts.config.SecureActionConfig">
...
</action-mappings>


I then configured the Secure Plugin in my struts-config.xml


<plug-in className="org.apache.struts.action.SecurePlugIn">
<set-property property="httpPort" value="8080"/>
<set-property property="httpsPort" value="8443"/>
<set-property property="enable" value="true"/>
<set-property property="addSession" value="true"/>
</plug-in>

I then added <set-property property="secure" value="true"/> to one of my actions that i want to be secure.

e.g.

<action path="/login" forward="login.page">
<set-property property="secure" value="true"/>
</action>


I then start tomcat (which is configured for use with ssl and tested and worked).

I then go to my application using just http on port 8080 and click on login which fires the /login action but it doesn't switch to ssl.
I was expecting is to switch and use port 8443 which is the correct ssl port on my tomcat server, but it doesnt change at all.

There are no errors on startup or anything.

I put a debugger in the SSLExtCommand class and the breakpoint is never hit, so this classes execute method is not being used.

Does anyone have any suggestions?

Please remember i am using struts 1.3.5 and also the tiles plugin to manage my pages.

Thank you for any help with this as its driving me crazy.

Cheers

Patrick
Patrick McDonogh
Ranch Hand

Joined: Oct 13, 2005
Posts: 89
Does anyone know of another way to switch between http and https rather than using sslext?
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: SSLExt, Tiles, Struts 1.3.5
 
Similar Threads
does not start with a "/" character
Chain-config in core struts and Tiles in Struts 1.3
Struts + Tiles Error
SSLEXT and Struts 1.2.9
SSL