File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Sockets and Internet Protocols and the fly likes SNMP MIB compilation error - Lexical error [0050] Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » Sockets and Internet Protocols
Bookmark "SNMP MIB compilation error - Lexical error [0050]" Watch "SNMP MIB compilation error - Lexical error [0050]" New topic
Author

SNMP MIB compilation error - Lexical error [0050]

Anil Juthani
Greenhorn

Joined: Feb 28, 2012
Posts: 1
Hi,
I am new to SNMP4j and have a question related to MIB file compilation. I try to modify a MIB file that compiles perfectly fine by editing the String value for an Object Identifier. However, once I do that, I am unable to compile the file again. I tried through MIBDesigner, MIBExplorer, MIBBrowser and AgentPro2 - same error message pops up which reads:

[0050] Lexical error at line 1, column 1. Encountered: "\u00ac" (172), after : "".

Not quite sure what its complaining about. It looks like it does not like one of the generated character, but not sure how to get around this. Any help would be appreciated.
Thanks and regards,
A.J.
 
 
subject: SNMP MIB compilation error - Lexical error [0050]