aspose file tools*
The moose likes Tomcat and the fly likes Cannot configure SSI on Tomcat 7.0.26 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Cannot configure SSI on Tomcat 7.0.26" Watch "Cannot configure SSI on Tomcat 7.0.26" New topic
Author

Cannot configure SSI on Tomcat 7.0.26

James Fraley
Greenhorn

Joined: Feb 28, 2012
Posts: 4
Hi. I'm new to administering Apache, so please be kind. I'm trying to get SSI to work on Apache 7.0.26 with JDK 6 update 31. I've tried to configure it on both windows and Linux and get the same result, so I'm reasonable sure it's a configuration issue. What I've done is:

1: Install a clean copy of windows (or Linux)
2: Install JDK 6u31
3: Install Tomcat 7.0.26
4: Test the install to ensure it works (and it does)
5: create the main.shtml and sub.html
6: Edit the web.xml to enable the SSI filter or the SSI
7: Try the load main.shtml and I get nothing... But I do get the following error in the Tomcat7-stderr log: SEVERE: Error filterStart

I've found 2 possible errors. First that there could be a conflict between the version of java that tomcat was compiled with and the version that was running. Second, that the context needs to be marked as privileged.

I know this is a possible security hole, but I'm the sole user.

I've wasted 2 days on this problem. So, I REALLY appreciate any help you can offer.

Thanks
Jim

-------------------------------web.xml-------------------------






-------------------------------main.shtml-------------------------


-------------------------------sub.html-------------------------


-----------------------tomcat7-stderr.2012-02-28.log


James Fraley
Greenhorn

Joined: Feb 28, 2012
Posts: 4
After 2 days and 1000s of attempts, it was setting privileged="true" in the context.xml file.



I hope this might help someone else avoid the pain.

Jim
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot configure SSI on Tomcat 7.0.26
 
Similar Threads
Tomcat and apache configuration in debian
Why jdk6x is not compatiable with Tomcat7? why jdk7x compiled classes are not working in jdk6x
Spring2.5.6+Tomcat7: HTTP Status 404: The requested resource () is not available
HTTP status 404 error from Tomcat
404 error and unable to deploy the project