This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Tomcat service not running after installing XAMPP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat service not running after installing XAMPP" Watch "Tomcat service not running after installing XAMPP" New topic
Author

Tomcat service not running after installing XAMPP

A. M. Anisul Huq
Greenhorn

Joined: Aug 11, 2009
Posts: 13
I have followed the following steps to install XAMPP 1.7.7 in Windows 7 Home(64-bit)

1. I downloaded the ZIP file instead of the the EXE file, and saved it to the "Downloads" folder.

2. Using WinRAR I extracted all contents within it.

3. After extracting the ZIP file, I moved the newly created "xampp" folder from "Downloads" to "C:\"

4. Next, I turned off the User Account Control (UAC).

5. Then, navigated to "C:\xampp" and created a shortcut to the Desktop.

Ran the new XAMPP Control Desktop shortcut and "Start"ed the ones for MySQL, Apache and Tomcat. For, MySQL, Apache I see a green "Running" indicator.
However, for Tomcat NOTHING. The log shows that Tomcat has started on port 8080, but in reality it is not and I am not seeing green "Running" indicator.


When I open up Web Browser, and type in http://localhost I see the XAMPP splash screen. But, if I try with http://localhost:8080, it shows "unable to connect".
If I go to Tomcat Status I see:


XAMPP Status This page offers you one page to view all information about what's running and working, and what isn't working.

MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service DEACTIVATED
Tomcat Service DEACTIVATED


Why is Tomcat DEACTIVATED? I have tried to install XAMPP 1.7.7 with .EXE file and the same thing happens. How can I fix this?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat service not running after installing XAMPP
 
Similar Threads
Tomcat service on Windows 7 - Cannot access web app from remote computer
how to start and stop tomcat 5.5 server
"Head First Servlets & JSP" tomcat instructions
Need help in installation of tomcat5.0.28
Tomcat Installation