• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Support for Migration from Axis 1.2 to 1.6.1 - JAXB Parser error

 
Sathyanarayanan Velu
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have done the following upgrade.

My Server was running on HPUX with a webservice using Axis2 1.2 + (Wsdp 1.0, Axiom 1.2.4)
Upgraded to Axis2 1.6.1 (Wsdp 2.1.7, Axiom 1.2.12).

The server startup is OK. The request and Error Response are fine. The following parsing error pops up
during marshalling when we submit the SOAP request via SOAP UI. The schema is not changed during the
upgrade. i.e. The same SOAP Request when submitted from my Notebook to my other HPUX Server
(with Axis2 1.2 without any upgrade) it is getting parsed and a success response.

Request sent is :



Response we get is


Logging in the Server:


[2012-03-07 12:15:38,9size44] DEBUG - login called
[2012-03-07 12:15:39,022] INFO - SOAP request processing starting
[2012-03-07 12:15:39,023] DEBUG - Build the OMElement in0 by the StaxSOAPModelBuilder
[2012-03-07 12:15:39,027] DEBUG - Build the OMElement neId by the StaxSOAPModelBuilder
[2012-03-07 12:15:39,028] DEBUG - Build the OMElement command by the StaxSOAPModelBuilder
[2012-03-07 12:15:39,028] DEBUG - Build the OMElement clustering by the StaxSOAPModelBuilder
[2012-03-07 12:15:39,029] DEBUG - The value of xsi:type is S12MMCType
[2012-03-07 12:15:39,029] DEBUG - Calling MTOMXMLStreamWriter.flush
[2012-03-07 12:15:39,029] DEBUG - Calling MTOMXMLStreamWriter.flush
<sos:requestCreate xmlns:sos="http://alcatel.pl/soserver/">
<ns1:in0 xmlns:ns1="http://company.in/myserver/" xmlns="http://company.in/myserver/PluginPSTNCommand/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="CommandType">
<neId>PSTN_12</neId>
<command>VIEW-GROUP;</command>
<clustering>STANDALONE</clustering>
</ns1:in0>
</sos:requestCreate>
2012-03-07 12:15:39,056] INFO - ActionStarting for ne :null:Parsing started...
[2012-03-07 12:15:39,056] DEBUG - Block size 1
[2012-03-07 12:15:39,056] DEBUG - smc.subscriber_mgmt.so_server.core.xsd.SoBlock$Create
[2012-03-07 12:15:39,092] DEBUG - REPORT PARSER ERROR
[2012-03-07 12:15:39,092] ERROR - Line:Col[-1:-1]:cvc-complex-type.2.4.a: Invalid content was found starting with element 'ns5:clustering'. One of '{"http://company.in/myserver/PluginPSTNCommand/":neId}' is expected.
[2012-03-07 12:15:39,092] DEBUG - WRITING RESPONSE TO LOGS
[2012-03-07 12:15:39,092] DEBUG - userName :vsathyan
[2012-03-07 12:15:39,092] DEBUG - WRITING RESULTS TO DIRECTORY
[2012-03-07 12:15:39,112] DEBUG - Line:Column[-1:-1]:cvc-complex-type.2.4.b: The content of element 'document' is not complete. One of '{"http://company.in/myserver/":block, "http://company.in/myserver/":Create, "http://company.in/myserver/"elete, "http://company.in/myserver/":Configure, "http://company.in/myserver/":UnConfigure, "http://company.in/myserver/":Modify, "http://company.in/myserver/":Get, "http://company.in/myserver/":serviceResult}' is expected.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic