aspose file tools*
The moose likes Struts and the fly likes class not found Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "class not found" Watch "class not found" New topic
Author

class not found

deepak bagdiya
Greenhorn

Joined: Sep 13, 2007
Posts: 6
Following is the message that I am getting :
0000024 RequestProces I org.apache.struts.action.RequestProcessor process Processing a 'GET' for path '/logon'
[9/26/07 13:15:21:268 EDT] 00000024 RequestUtils E org.apache.struts.util.RequestUtils createActionForm Error creating form bean of class logonForm
java.lang.ClassNotFoundException: com.Logon
at com.ibm.ws.classloader.CompoundClassLoader.findClass(CompoundClassLoader.java(Compiled Code))
at com.ibm.ws.classloader.CompoundClassLoader.loadClass(CompoundClassLoader.java(Compiled Code))
at java.lang.ClassLoader.loadClass(ClassLoader.java(Compiled Code))
at org.apache.struts.util.RequestUtils.applicationClass(RequestUtils.java:193)
at org.apache.struts.util.RequestUtils.applicationInstance(RequestUtils.java:219)
at org.apache.struts.util.RequestUtils.createActionForm(RequestUtils.java:625)
at org.apache.struts.action.RequestProcessor.processActionForm(RequestProcessor.java:351)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:245)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1292)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:492)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1282)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:673)
at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:2933)
at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:221)
at com.ibm.ws.webcontainer.VirtualHost.handleRequest(VirtualHost.java:210)
at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:1912)
at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:84)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:472)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:411)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:288)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminaters(NewConnectionInitialReadCallback.java:201)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:103)
at com.ibm.ws.tcp.channel.impl.WorkQueueManager.requestComplete(WorkQueueManager.java:566)
at com.ibm.ws.tcp.channel.impl.WorkQueueManager.attemptIO(WorkQueueManager.java:619)
at com.ibm.ws.tcp.channel.impl.WorkQueueManager.workerRun(WorkQueueManager.java:952)
at com.ibm.ws.tcp.channel.impl.WorkQueueManager$Worker.run(WorkQueueManager.java:1039)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1462)

Please advise

Thanks,
Deep Bagdiya
[ September 26, 2007: Message edited by: deepak bagdiya ]
deepak bagdiya
Greenhorn

Joined: Sep 13, 2007
Posts: 6
How do I edit my posted question.

Thanks,
Deep Bagdiya
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41509
    
  53
By clicking the little paper-and-pencil icon ()


Ping & DNS - my free Android networking tools app
Merrill Higginson
Ranch Hand

Joined: Feb 15, 2005
Posts: 4864
This is a Struts problem. The message is telling you that you defined an Action in your struts-config.xml file with a path of "/login" for which you specified a type of "com.Login", and there is no such class anywhere in the classpath. Did you missspell it? Are you sure you compiled it and that the class file exists in WEB-INF/classes?


Merrill
Consultant, Sima Solutions
deepak bagdiya
Greenhorn

Joined: Sep 13, 2007
Posts: 6
Sorry.I did not post the actual file name.I changed the actual file name while posting .I can see the class file in WEB-INF /classes folder.But am still getting that message.I am using RAD6 with embedded test server.
Earlier the application was working fine.Then I took all the updates from our CVS server and I started getting this message.
I installed wasd5.1 and the application is working fine on it.
But I still want to fix this error for RAD6 so that I can use version 6
of websphere.

Thanks,
Deep Bagdiya
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: class not found