File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Other Java Products and Servers and the fly likes remote machine clustering fails Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "remote machine clustering fails" Watch "remote machine clustering fails" New topic

remote machine clustering fails

Jordan Josh
Ranch Hand

Joined: Aug 23, 2008
Posts: 38
Hi Friends,

I am trying to create clustering between two different machines on linux with glassfish 3.1.1.
I am able to create clustering on single machine but when it comes to
remote machine gives me error.I tried with GUI also but getting the same

I am using one machine as DAS and created localnode and local instances
on DAS,then tried to create remotenode and instance on remote machine.

For Remote machine Steps:

1)create-node-ssh --nodehost <remotemachineip> node1 --port 14848
node is created successfully and reflect in domain.xml

2)list-nodes-ssh --long=true --port 14848
Getting list successfully

3)ping-node-ssh node1 --port 14848 -getting ping successfully

4)create-cluster --port 14848 --multicastaddress
--multicastport 2048 phmscluster

5)start-cluster --port 14848 testcluster

6)create-instance --cluster testcluster --node node1 --user admin
--host <remotemachineip> --port 14848 phmsinstance1

After step number 6 it gives me error:

Command failed on node node1 (remotehost): Could not contact the DAS running
at localhost.localdomain:14848. This could be because a firewall is blocking
the connection back to the DAS or because the DAS host is known by a
different name on the instance host localhost.localdomain. To change the
hostname that the DAS uses to identify itself please update the DAS
admin HTTP listener address.

Command _create-instance-filesystem failed

Please,Can any one help me?

I agree. Here's the link:
subject: remote machine clustering fails
It's not a secret anymore!