aspose file tools*
The moose likes JForum and the fly likes SecurityException when rendering template Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "SecurityException when rendering template" Watch "SecurityException when rendering template" New topic
Author

SecurityException when rendering template

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Maybe someone here will be able to help, I have taken this as far as I can for now...

I'm developing a web portal based around JForum, and rathe than integration JForum into a CMS I'm extending it to become the CMS. Right now I have two directories in my work dir: jforum and crapaud.

jforum is the CVS tree and crapaud contains the jars, my code, custom config, and a symlink to src/net/jforum. The idea is that I can continue to base my stuff around updates in CVS.

Anyway, as it stands there are very few changes from the base code right now, and so crapaud is very close to jforum in content, with only DB changes, and few small things (I've subclassed JForum to Crapaud as my entry point.

However, after building I try to access this page: http://testserver:8080/crapaud/forums/list.page and I get this Expcetion in the logs:



For some reason freemarker is trying to load the template from the wrong path.

My Context entry in server.xml looks like:




and web.xml is



Anyone know why this is happening?

Arawak
[originally posted on jforum.net by Arawak]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Okay, everyone can relax now, I figured it out :-)

My templates/default was a symlink to the jforum directory!

Doh!

Arawak
[originally posted on jforum.net by Arawak]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
yeah, I was going to ask if wasn't the symlink the root of the problem!!

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: SecurityException when rendering template
 
Similar Threads
Starting...
Simple panelTabbedPane
i looked at log file and not know to correct
why do i get this error.. if a lot of people are connected
Parsing error processing resource path /WEB-INF/struts-config.xml