File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

System requirements, JVM version?

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have looked and have not found which baseline JVM version is necessary for JForum 2.0. What is it? Java 1.3.1 or 1.4 or 5.0 Tiger?

I hope to run JForum on a FreeBSD server and the latest stable Java release is 1.3.1 so I am restricted to that version. I hope JForum does not required Java 1.4.

Brennan (brennan - offwhite.net)
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JForum requires Java 1.4 or newer. I'll put this information in the FAQ.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What if your application server is running 1.3 and you cannot upgrade.

Is there way to make JForums point to a different directory where the files of JDK 1.4 could be stored?
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have to start the servlet container pointing to the 1.4 VM. JForum will not run at all under 1.3

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic