File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JForum and the fly likes v 2.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "v 2.1" Watch "v 2.1" New topic
Author

v 2.1

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
clicking on "email" in user list puts a space after "@"

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hm, right. The fixed file is attached to this message. Put it under templates/default

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
1. Login as regular user and go to the Member Listing -- you will see all e-mails, also of those users who want to hide their e-mails.

2. Go to user profile and remove e-mail, click Save, you will get an error message that e-mail is required. Now go to any other page and return to user profile -- there is no e-mail (the old e-mail is not saved)

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, here we go:

1) http://www.jforum.net/jira/browse/JF-252
2) http://www.jforum.net/jira/browse/JF-253

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
JF-252 should be fixed as quick as possible as it affects user privacy.

Here is another report: "User Activation message subject" and "User Activation message file" in Configurations are not saved when clicking Update button.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I updated the package with jf-252 fixed. However, jf-253 I cannot reproduce.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael,

I just re-installed version 2.1 on local computer and "user listing show email even when user choose to hide it" (jf-252). Where to get a fixed version?

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I uploaded the fixed package a couple of minutes ago. Please download 2.1 again from sf.net

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi Rafael,

here is another issue. When the user clicks "I lost my password" and enters his e-mail, a message with subject "[JForum] - Password recovery" will send.

Please make this "[JForum]" configureable ("[MyForumName]"), similar to configureable subjects in other e-mail templates.

I still see all emails in the list of users (252), will try later again, may be it takes the time to propogate changes in the new version accross SF repositiories..

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
From which country are you? This is a problem with Captha, and the error occurs because the area to draw the image is less than the area filled by the words. You can disable it by setting the key "captcha.registration" to "false" in the file WEB-INF/config/SystemGlobals.properties.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Fine, hidden emails not shown in the list of users (252).
Thanks!
Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
the fellowing message appears everytime on the Register page, and the page won't work.

it was working fine with v2.0.2


[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael,

Changing to language to any of the ones you included in version 2.1 generates the following error:


Expression I18n.getMessage("ForumBase.search") is undefined on line 36, column 186 in default/forum_base.htm. The problematic instruction: ---------- ==> ${I18n.getMessage("ForumBase.search")} [on line 36, column 184 in default/forum_base.htm] in include "default/forum_base.htm" [on line 4, column 1 in exception.html]

Regards

Jorge
[originally posted on jforum.net by jmantilla]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael Steil wrote:From which country are you? This is a problem with Captha, and the error occurs because the area to draw the image is less than the area filled by the words. You can disable it by setting the key "captcha.registration" to "false" in the file WEB-INF/config/SystemGlobals.properties.

Rafael


Hola, Rafael,

that post was mine, I chated you on msn days ago, remember?
I'm from Taiwan and using traditional chinese.
I tried to reinstall jforum and set en_US as the default language, but the problem remained.
[originally posted on jforum.net by digi2fish]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
BTW, it works now, thanks.
[originally posted on jforum.net by digi2fish]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
jmantilla wrote:Rafael,

Changing to language to any of the ones you included in version 2.1 generates the following error:


Expression I18n.getMessage("ForumBase.search") is undefined on line 36, column 186 in default/forum_base.htm. The problematic instruction: ---------- ==> ${I18n.getMessage("ForumBase.search")} [on line 36, column 184 in default/forum_base.htm] in include "default/forum_base.htm" [on line 4, column 1 in exception.html]

Regards

Jorge


hhhmm.. Ok, I registered this bug: http://www.jforum.net/jira/browse/JF-256. I'll fix it and update the 2.1 package.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I upgraded recently to 2.1. Then, after a few messages were posted, the number in the Topics column is WRONG!

Rafael, please fix this!

PS: Also here, for example, in the Contributors forum the number of Topics is 60, while the real number of topics is 15+15+11 = 41

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
hhmm..maybe a problem with the cache? if you restart tomcat, the number shown is correctly?

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
No, restart doesn't help. I believe the counter of topics increased INSTEAD of counter of messages!


Now more badly. A new member cannot confirm registration

[ERROR [ExceptionWriter ] java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25
)
at java.lang.reflect.Method.invoke(Method.java:585)
at net.jforum.Command.process(Command.java:106)
at net.jforum.JForum.service(JForum.java:298)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:809)
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Well, there is a counter for both topics and messages. I'll take a look. Also, while I try to find and fix the registration confirmation problem, you may opt to disable it.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I just tryed to register as new user and when click on confirmation link I got: The activation key is invalid.


Evgeny
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I'm working on that.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael, how I (admin) can manually confirm the user?
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
You can't. The only way wil be to do that manually, in the database:



Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I fixed the bug with user registration confirmation. The update is in the attached file.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael, please update the SF, too.

Please fix the counter. Looks like it counts messages, not topics.
Thanks!
Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
If it was counting messages, the difference would be THAT big. I'll announce when I have a fix for it (IF I could idenfity the bug).

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I believe it counts messages, not topics, since the release 2.1, so the difference still currently not very big, but grow with each new post.

And please update SF with the fix of registration confirmation, I will re-install my forum tomorrow.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Nope, I'm sure it is couting topics. The problem is that jforum_forums have a field called "forum_topics", which is incorrectly updated in many parts of the code. If you see, the post counting is correct (or very close ot).

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:I
And please update SF with the fix of registration confirmation, I will re-install my forum tomorrow.


You don't need to reinstall. Just copy the directory WEB-INF over the existing one and you'll be fine.


Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
By the way!!!

Following this catastrophic defect I suggest to allow the admin of the forum to post "short messages" in the very top of the forum, above the "Forum Index" line.

This will take attention of all users about important things.

Please add to you "To Do".
Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I have fixed the bug related to wrong number of topics. I'm uploading jforum 2.1 (AGAIN :P) to sf.net. To fix the number of topics, please run the following query:



Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I did, looks good

The last thing, if you can allow a custom forum name, instead of [JForum], in subject of the Password Recovery e-mail, that would be great !

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I added it as requested and updated the package. I guess that know I could be able to publish version 2.1 at TSS ;)

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
What is TSS?

Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:What is TSS?

Evgeny


the server side
[originally posted on jforum.net by cnticws]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: v 2.1