Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts - Show Loading Gif when loading a page

 
Kevin Vercauteren
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone,

Im building a STRUTS application for my company and i wanted to implement a JS in my JSP pages.

The Page is accessed via a normal struts Action, everything works with Opera and

I found an example on the web wich works perfectly in Opera and Firefox but wont work in Internet Explorer 7

The DIV Layer does show in IE7 but it wont go away after the page is loaded ..



With FF and Opera this isn't a problem

Im using the following example i found:

http://www.webmasterworld.com/forum21/7586.htm

If maybe someone has a solution or better option to make this work.

Thanks in advance

Kind Regards Kevin
[ December 04, 2007: Message edited by: Kevin Vercauteren ]
 
Brent Sterling
Ranch Hand
Posts: 948
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not sure there is anything Struts specific about this question. Here is a page that I bookmarked a while back because it looks pretty cool...but I have not tried the solution:

http://blogs.crsw.com/mark/articles/642.aspx

- Brent
 
Kevin Vercauteren
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for your reply Brent

I will look up to this solution

I also found someone who had the same problem as me on the next link:

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=943224&SiteID=1

I also got the same problem. After doing some research I found out the root cause of the problem (atleast for my case). But I don't have any solution on how to get rid of this issue. May be Microsoft can address this.

The issue is when "IE 7.0 is sending request" or "when there is some serious stuff being done on the server side" IE 7 is not able to play animation in the gif image. It is showing the image but it is not playing any animation stuff. For example in my "jsp"(JavaServer Pages) I have an animated gif image that contains progress bar kind of thing that moves from right to left (repeats) continously when user selects an file (path) and clicks upload button. The animated gif works fine in IE 6.0 and FF 1.5 but not in IE 7.0. The progress bar stands still at a position in IE 7.0 when the form is getting "submitted" (or when "sending request").

But when I open the same image in IE 7.0 directly by giving the file path in the address bar it is working perfect with all animation. So I think there is some defect with IE 7.0 with animated gif images not being played when the form is getting submitted or request is being sent.

If anyone has an work around for this issue please post here.

Thanks,
Pro
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic