This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes JForum and the fly likes Error I got when I clicked on Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Error I got when I clicked on "Recent Topic" after editing the Categories and Forums in the Admin Co" Watch "Error I got when I clicked on "Recent Topic" after editing the Categories and Forums in the Admin Co" New topic
Author

Error I got when I clicked on "Recent Topic" after editing the Categories and Forums in the Admin Co

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Please open the page source code when you get this error. The detailed message will be there. Please put it there.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
This was the error I got when I clicked on "Recent Topic" after editing the Categories and Forums in the Admin Control Panel.
An error has ocurred. For detailed stack trace, please see the page's source code.
java.lang.reflect.InvocationTargetException
Any Advise.

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
<!-- BEGIN ERROR STACK TRACE <br /> java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:585) <br /> at net.jforum.Command.process(Command.java:106) <br /> at net.jforum.JForum.service(JForum.java:298) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:802) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) <br /> at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214) <br /> at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178) <br /> at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126) <br /> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105) <br /> at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107) <br /> at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148) <br /> at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:306) <br /> at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:385) <br /> at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:745) <br /> at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675) <br /> at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:868) <br /> at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) <br /> at java.lang.Thread.run(Thread.java:595) <br /> Caused by: java.lang.NullPointerException <br /> at net.jforum.repository.ForumRepository.getForum(ForumRepository.java:367) <br /> at net.jforum.view.forum.common.TopicsCommon.isTopicAccessible(TopicsCommon.java:201) <br /> at net.jforum.view.forum.RecentTopicsAction.topics(RecentTopicsAction.java:91) <br /> at net.jforum.view.forum.RecentTopicsAction.list(RecentTopicsAction.java:74) <br /> ... 22 more <br /> <br /> END ERROR STACK TRACE-->
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hm.. looks like some permission problem. Go to Admin Panel -> Groups -> Permissions, set "Allow all" to all categories and forums, save, and see if it works.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error I got when I clicked on "Recent Topic" after editing the Categories and Forums in the Admin Co
 
Similar Threads
Others Foruns Good Ideas
Creating Category Fails
Categories and forum names won't show up in admin panel
Error when run migration script
New Category Problems