This week's book giveaway is in the Java 8 forum.
We're giving away four copies of Java 8 in Action and have Raoul-Gabriel Urma, Mario Fusco, and Alan Mycroft on-line!
See this thread for details.
The moose likes JForum and the fly likes Error saving group permissions Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Error saving group permissions" Watch "Error saving group permissions" New topic
Author

Error saving group permissions

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello,
I'm running JForum 2.1.4 and I get the following error when I try to save group permissions:


The table does exist so I don't know where the problem lies.
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm guessing you are using MySQL 4.1. I had the same problem ;)
Copy the sql file for 4.1 (mysql4.1.sql or something like that) over the normal one (mysql.sql) in the WEB-INF/config/database/mysql directory.
[originally posted on jforum.net by mortis__rigor]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks that worked, BUT I had to add the following to the new mysql.sql (ie the mysql4_1.sql):



After adding that entry it worked as expected
[originally posted on jforum.net by Anonymous]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error saving group permissions
 
Similar Threads
Oops. Got in trouble upgration from 2.0 to 2.1.4
Unable to turn on the attachment button
Error setting permission on a group.
Unknown table jforum_role_values error
Help me!