aspose file tools*
The moose likes JForum and the fly likes need graphics server to register? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "need graphics server to register?" Watch "need graphics server to register?" New topic
Author

need graphics server to register?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Just finished installing Jforum on my headless linux server. When clicking the 'register' link, I get this error:


An error has ocurred. For detailed stack trace, please see the page's source code.
Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.

The Tomcat log has this stack trace:




Any ideas?
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ah, figured it out. I turned off the 'Captcha' functionality in the admin tool.

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Take a look in this post:

http://www.coderanch.com/t/574500

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks for the info, Rafael. I've decided to just run headless and disable Captcha. This will also disallow avatars, evidently, but I can live with that.

I still have the issue ( in the other thread - http://www.coderanch.com/t/575213 ) where I am having a problem with disallowing Anonymous posts for a specific forum. Can you help with that?

Thanks,
Pat
[originally posted on jforum.net by heehaw]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: need graphics server to register?