aspose file tools*
The moose likes JForum and the fly likes Oops. Got in trouble upgration from 2.0 to 2.1.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Oops. Got in trouble upgration from 2.0 to 2.1.4" Watch "Oops. Got in trouble upgration from 2.0 to 2.1.4" New topic
Author

Oops. Got in trouble upgration from 2.0 to 2.1.4

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello,

Tried to upgrade from 2.0 to 2.1.4. Ran SQL script 2.0.2->2.1.4. Now when saving group permissions, I get:

An error has ocurred. For detailed stack trace, please see the page's source code.
Unknown table 'jforum_role_values' in MULTI DELETE

No databse backup.

Any advice to get out of trouble?


Thanks,

Jean-Robert
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Take a look here:

http://www.jforum.net/confluence/display/configuration/MySQL+3.23

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I have the same problem, but using mysql 4.1.7

Where are the settings for the mysql version to be used?

Thanks
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Try this file:

https://jforum.dev.java.net/source/browse/jforum/WEB-INF/config/database/mysql/Attic/mysql_41.sql?rev=1.2&view=auto&content-type=text/vnd.viewcvs-markup

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Oops. Got in trouble upgration from 2.0 to 2.1.4
 
Similar Threads
JFORUM_ROLES entry with user id '0'
Package org.jboss.cache not found when compiling JForum 2.1.4
Which version to install?
After moving files into Tomcat, get an error when opening page
Developer setup?