This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JForum and the fly likes Search Nothing in UTF8 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Search Nothing in UTF8" Watch "Search Nothing in UTF8" New topic
Author

Search Nothing in UTF8

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello,
I have installed JForum 2.1.4 with MySQL 4.1.14, and it works well.
The character encoding is UTF-8 for Tranditional Chinese, and display is OK.
But I cannot search anything in Tranditional Chinese. (English is OK)

Anyone has same problem?

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I use Simplified Chinese�?� have same problem
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
2.1.4 has in fact problems with cirylic chars. 2.1.5 should do better.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I found the same problem in 2.1.5.
I use UTF-8 encoding for Simplified Chinese.

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Searching whole text in 2.1.5 will get the right result,but searching a part will get nothing.
For example,the subject is "��܏��?���",and the criteria is "��܏��?���",you will get right result;
when criteria is "��܏�" or "���" etc.,you will get nothing.

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Searching whole text in 2.1.5 will get the right result,but searching a part will get nothing.
For example,the subject is "��܏��?���",and the criteria is "��܏��?���",you will get right result;
when criteria is "��܏�" or "���" etc.,you will get nothing.

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Yeah, that's either weird and dificult to handle.

We're trying to improve that, though. If you have any hits, please share with us

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
We still don't have a definite fix. Specially with myslq, this is hard to get working correctly.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
jdk1.5,tomcat5.0,mysql5.0

[img]http://img321.photo.163.com/michael.panger/38430302/1042090826.jpg
[/img]



help please!
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
JForum 2.1.6
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
thank, Rafael
[originally posted on jforum.net by michael.panger]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
��܍��mvnforum��?�?��Ќ??�?��?Ί�?�ٴ���??���Ӭ�?ٍ?�jforum��?�Ӭ��?lucene�?ΎѨ�����?�����?�?��?�
[originally posted on jforum.net by recht]
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Search Nothing in UTF8
 
Similar Threads
Is any Chinese here ?
JForum2.1.4 bug
Chinese processing problem in JSP
Also took test today
Search Function doesn't work