aspose file tools*
The moose likes JForum and the fly likes Problems while connecting to mysql db on linux Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Problems while connecting to mysql db on linux" Watch "Problems while connecting to mysql db on linux" New topic
Author

Problems while connecting to mysql db on linux

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I am using JForum since last few days and was able to get it working fine on windows. While I deployed the same on Linux (Fedora core 3), I am getting -

net.jforum.exceptions.DatabaseException: Error while trying to start the database: javax.naming.NameNotFoundException:<XXXXDS> not bound.

Please let me know what am I doing wrong.

Env - Fedora core 3, JBoss 4.0, Mysql 4.1

Thanks,

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Did the JForum install complete successfully? If not, did you create the JForum database before starting the install?

Can you log into mysql via the command line and access the JForum database?

This can be done like this:

> mysql -u YOUR_JFORUM_DB_USER_NAME -p <Enter>

You will be prompted for the JFORUM_DB_USER_NAME password.

At the mysql prompt, type in: use jforum; <Enter>
then: show tables; <Enter>

If any of these steps fail, there is a problem with your mysql DB user permissions/password.

If all of that works correctly, you may need to check your myslq config settings.


[originally posted on jforum.net by GatorBait3]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems while connecting to mysql db on linux
 
Similar Threads
Rails MySQL BLOB support
b1.addActionListener( this);
jsch file copy from Linux to Windows
Internationalization
Most sophisticated Windowing system?